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The Adobe Creative Cloud (CC) Package provides many creative editing tools for Windows and OS X
including Acrobat, Illustrator, Photoshop, Dreamweaver, Premiere, and more. Adobe CC is
available to SJSU and CSUMB faculty, staff, and students at no-cost for the entire duration of their
affiliation with either institution.

Installation of Adobe CC requires 50 GB of free space on the hard drive (HD). Please make sure that
your computer system meets the requirements and has sufficient HD space before beginning the
installation. System requirements for Mac OSX and Windows may be found here.

NOTE: Follow this procedure to access Adobe Creative Cloud on both personal and
state/foundation owned computers. You will be able to install Adobe CC on as many computers as
you like and actively use Adobe Apps on two computers at a time.

1. Fill out the Adobe Access Form using your SJSUOne ID and password
1. Student Adobe Access Form
2. Faculty/Staff Adobe Access Form

2. If you are eligible, click Register

 
3.  You will receive an email from Adobe to your SJSU gmail account within a few hours of

submitting the form.

Adobe Creative Cloud
Information & Installation

System Requirements

Adobe CC Access & Installation Procedure
SJSU Faculty, Staff, and Students

https://helpx.adobe.com/in/creative-cloud/system-requirements.html#requirements
https://adobelicensing.sjsu.edu/Login?ReturnUrl=%2fEligibility%2fDefault.aspx
https://adobelicensing.sjsu.edu/Login?ReturnUrl=%2fEligibility%2fDefault.aspx
https://kb.mlml.sjsu.edu/uploads/images/gallery/2021-08/screenshot.png


4. Open the email and click Get Started

5. Sign into SJSU's single sign on portal by entering your SJSU ID and password and verify
using DUO

6. You will be redirected to Adobe's homepage where you will see the option to install Adobe
CC

7. For detailed instructions on how to install Adobe CC and Adobe Apps reference this
Installation and Resource Guide

NOTE: Follow this procedure to access Adobe Creative Cloud on both personal and
state/foundation owned computers. You will be able to install Adobe CC on as many computers as
you like and actively use Adobe Apps on two computers at a time.

1. Navigate to adobe.com
2. Click Sign In in the upper right corner and enter your CSUMB email address

CSUMB Faculty, Staff, and Students

https://kb.mlml.sjsu.edu/uploads/images/gallery/2021-08/screenshot3.png
https://www.sjsu.edu/ecampus/docs/Adobe-SJSU-intall-guide.pdf
https://www.adobe.com/


3. Click Continue

4. You will be redirected to CSUMB's single sign on, enter your username and password
5. You will again be redirected back to Adobe's website, and you now have access to Adobe

CC
1. Here you can install the Adobe CC app onto your computer and use it to install the

programs you want from the Adobe CC App

1. Sign out of the Creative Cloud Desktop app and close it
2. Open File Explorer (windows) or Finder (mac) and navigate to the ServiceConfig.xml file:

Windows: C:\Program Files (x86)\Common
Files\Adobe\OOBE\Configs\ServiceConfig.xml
MacOS: Macintosh HD/Library/Application
Support/Adobe/OOBE/Configs/ServiceConfig.xml

3. Copy ServiceConfig.xml to your desktop
4. Open the copy of the ServiceConfig.xml file with Notepad (windows) or TextEdit (mac)
5. Change the following line from

<panel><name>AppsPanel</name><visible>false</visible></panel>
to
<panel><name>AppsPanel</name><visible>true</visible></panel>

6. Save the copy of the ServiceConfig.xml file to your desktop
7. Rename the original ServiceConfig.xml file in the Configs folder to ServiceConfig-old.xml
8. Copy and paste the altered ServiceConfig.xml file from your desktop into the Configs

folder
9. Restart your computer

10. You should now no longer receive the error message when installing new apps

Additionally, here are some video walkthroughs of the procedure described above:

Windows: https://www.youtube.com/watch?v=FyphY4QJk44

Troubleshooting
Adobe CC displays "You don't have access to manage apps" error
when installing apps

https://kb.mlml.sjsu.edu/uploads/images/gallery/2021-08/screenshot2.png
https://www.youtube.com/watch?v=FyphY4QJk44


MacOS: https://www.youtube.com/watch?v=jr2jlngK4wU

https://www.youtube.com/watch?v=jr2jlngK4wU


Windows

1. Open the image you want to convert to a PDF
2. Right click on the image and select "Convert to Adobe PDF"
3. Save the new PDF to the location of your choice

Mac

1. Open the image you want to convert to a PDF
2. Click File > Export as PDF
3. Save the PDF to the location of your choice

Windows and Mac

1. Open the word document you want to convert to a PDF
2. Click File > Save As
3. Select the location where you want to save the PDF
4. Select "PDF" as the file type from the drop down
5. Save the document

 

Save a Document or Image
as an Adobe PDF
Images

Word/Excel/PowerPoint Documents



This procedure has been verified on Adobe Acrobat 8 Professional:
(The procedure outlined should work with Acrobat v7, v8 and v9)

1. Save the document as a PDF.
(Instructions for creating a PDF are located here: Save a Document or Image as PDF)

2. Open the document in Adobe Acrobat (Adobe Reader cannot edit PDFs).
3. Navigate to the Forms menu.
4. Select Run Form Field Recognition and allow the conversion to complete.
5. Save the document as a PDF. (Choose a different file name to avoid overwriting your

original document)
6. Be sure to verify that all desired fields are fillable prior to distribution.

HINT: Use the "Highlight Fields" button or menu option to show which fields were
automatically created.

7. If more fields need to be created, use the "Forms" toolbar. Open the Forms toolbar from:
View > Toolbars or Tools > Forms > Show Forms Toolbar.

Once the fillable form has been created, users can fill the form using any standard PDF viewing
application.

For Adobe Acrobat Pro DC:

1. Save the document as a PDF.
(Instructions for creating a PDF are located here: Save a Document or Image as PDF)

2. Open the document in Adobe Acrobat (Adobe Reader cannot edit PDFs).
3. Within Acrobat, click on the Tools tab and select Prepare Form.
4. Select a file or scan a document. Acrobat analyzes your document and adds form fields

automatically.
5. Add new form fields from the top toolbar, and adjust the layout using tools in the right

pane.
6. Save your fillable PDF form and share it with others, or click Distribute to collect responses

automatically.

Convert a document to a
fillable PDF form using
Adobe Acrobat

https://kb.mlml.sjsu.edu/books/software/page/save-a-document-or-image-as-a-pdf
https://kb.mlml.sjsu.edu/books/software/page/save-a-document-or-image-as-a-pdf


More information about creating fillable PDFs is available on Adobe's website:
https://acrobat.adobe.com/us/en/acrobat ... eator.html

Also see our DocuSign FAQ to learn how to convert PDFs into fillable PDFs online.

https://acrobat.adobe.com/us/en/acrobat/how-to/create-fillable-pdf-forms-creator.html
https://kb.mlml.sjsu.edu/books/administrative-services/page/docusign-faqs


When having to fill out a PDF form, some forms can be filled electronically. If your PDF form is
fillable, here’s how you fill it out and print the completed form. For more information, see Adobe’s
Support Page on completing electronic forms.

 

1. Make sure you have Adobe Reader installed on your computer.

Faculty or staff members with a valid SJSUOne ID can use DocuSign to have recipients fill
out and sign documents online. Refer to our DocuSign FAQs for more information.
Download the fillable form onto your computer and open the file in Adobe Reader.
To make form fields easier to identify, click the Highlight Existing Fields   button on
the document message bar, if necessary.
Select the Hand Tool. 
Select the fillable highlighted field on your form. An I-beam will appear for you to type in
the text or arrow to select or check boxes.
Fill in the necessary information for each field.
Example: 

Once you have finished filling the form, Save your form by printing as a PDF in order to
email or print.

Windows:
Select File > Print.

How to Fill PDFs
Electronically Using Adobe
Reader

https://helpx.adobe.com/reader/using/fill-forms.html
https://helpx.adobe.com/reader/using/fill-forms.html
https://get.adobe.com/reader/
https://sjsu.okta.com/login/login.htm?fromURI=%2Fhome%2Fdocusign%2F0oab5wk2fzgtwvTpM0x7%2F292
https://kb.mlml.sjsu.edu/books/internal-resources/page/docusign-faqs


Choose Adobe PDF as the printer in the Print dialog box.
Click Print. Type a name for your file, and click Save.

MacOS:
Select File > Save As.
Select a location to save, type a name for your file, and click Save.
To flatten your form so that it cannot be edited, open the file in the MacOS
Preview application.
Select File > Export As PDF...
Select a location to save, type a name for your file, and click Save.



Create protected PDFs
Prevent others from copying or editing sensitive information

Edit PDF text and images 
Fix a typo or swap an image in a PDF from your computer, iPad, or Android tablet

Convert creative filed and images to PDF
Turn Adobe Photoshop, Illustrator, or InDesign files into PDFs

Simplify and speed up PDF reviews
Collect group feedback in one PDF file online with no reviewer login required. Let
reviewers see ea h other's feedback and clear up any confusion with @-mentions

Export PDFs to Office
Convert PDFs to Word, Excel, or Powerpoint and keep the formatting

Firstly, please visit our Adobe Creative Cloud Information and Installation page to get information
on how to access and download Adobe applications for free through your student account

Second, to find out how to use the Acrobat DC app to design and edit your documents, take a look
at the following tutorials from Adobe's website: 

Getting started with Acrobat DC
Use this webpage to learn the basics of Acrobat, including how to create a new PDF
file, edit and comment on your PDF file, and add a password to protect your file from
unwanted visitors

Adobe Acrobat
Adobe Acrobat is an application that
allows you to connect with your
documents, access essential PDF and e-
signature tools, and make collaboration on
PDF reviews easy from any device.
Here is a list of uses for the Adobe Acrobat DC app:

Getting started with Acrobat as an MLML student

https://kb.mlml.sjsu.edu/books/software/page/adobe-creative-cloud-information-installation
https://helpx.adobe.com/acrobat/tutorials.html
https://helpx.adobe.com/acrobat/how-to/get-started-acrobat-dc.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:orientation/en_us.json&ref=helpx.adobe.com


How to create PDFs from text and image files
How to customize your Acrobat toolbar 
How to combine files into one PDF 
How to create PDFs from Microsoft Office 
How to add annotations and sticky notes to your PDF
How to extract pages from a PDF 
How to split a PDF file
How to turn paper documents into searchable PDFs

 

https://helpx.adobe.com/acrobat/how-to/create-pdfs-from-text-image.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:orientation/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/customize-toolbar.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:orientation/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/combine-files-into-pdf.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:basictraining/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/create-pdf-files-word-excel-website.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:basictraining/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/add-pdf-comment.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:continuinged/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/extract-pages-from-pdf.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:continuinged/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/split-pdf-file.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:continuinged/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/scan-paper-documents-searchable-pdf.html

