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Microsoft Office



Discounts for MS Office for personal use are available for Faculty, Staff, and Students at SJSU and 

CSUMB OnTheHub.

Also, see the MLML Software Availability Page.

If your work computer is state-owned, and you would like to request an install of Microsoft Office,
please submit an IT Helpdesk Ticket.

Request Microsoft Office for
State-Owned Computers
 

Free versions of Microsoft Office are only available for state-owned
computers.

https://sjsu.onthehub.com/
https://csumb.onthehub.com/
https://mlml.sjsu.edu/itech/software/
http://helpdesk.mlml.calstate.edu


Note: If you are a student currently enrolled at MLML through SJSU or CSUMB, you can download
Microsoft Office 365 for free using your school email account.

The Microsoft Office 365 Education package provides all of the software that students normally
need, including Word, Excel, PowerPoint and more.

To download the package, please follow these directions carefully:

1. Go to this link.
2. Enter your school email address.

If you are an SJSU student, make sure you enter your @sjsu.edu address. If you are
a CSUMB student, enter your @csumb.edu address.

3. Click the button that says "I'm a student".
4. Enter the info needed to create a new account (You should have a new email in your

corresponding inbox containing your verification code. If you don't see it immediately, be
sure to check your spam folder).

5. Once all of the information is entered, click start.
6. Skip the invitations (or share with friends who might also need Office 365!)
7. Arrow through the promotion/tutorial box that pops up.
8. This should bring you to a page with Office 365 and a greeting at the top. From here you

can choose to either download and install the entire 365 package for your computer
(recommended if you have nothing on your computer), or just use the individual features
from online.

9. If you wish to install Office 365 on your computer, click the Install Office 2016 button in
the upper right hand corner of the page.

10. Double click the download to open the installer file.
11. Complete installation.
12. Sign in with the new account that you created to activate Office.

And voila! You should now have full access to Microsoft Office online and on your desktop.

 

Microsoft Office Installation
for Students

Troubleshooting: What to do if the school sign in page does
not work for you

https://products.office.com/en-us/student?ms.officeurl=getoffice365


*Before you begin, make sure you are completely exited out of the Microsoft page and SJSU/CSUMB
sign in page*

1) Log on to gmail in your web browser and sign in to your SJSU/CSUMB email

2) Click your name/account in the upper right corner and click "manage your google account"

3) Click "security" on the left hand side

4) Scroll down to "signing in to google" and click "password"

5) Follow the steps to reset your password

6) Exit out of the Gmail tab

7) Go back to the Microsoft sign up page and put in the new password you just made

8) It might take you through a series of verification steps for your phone number and a back-up
email address - follow these steps

9) This should lead you to the school's Microsoft page, click "install office" in the upper right hand
corner to download the suite
 

If you get stuck at step #4 in this process because your school email
address or password is deemed invalid, follow the guidelines below:

https://products.office.com/en-us/student?ms.officeurl=getoffice365


 

https://www.office.com/
http://www.microsoft.com/mac/
https://support.office.com/en-us/office ... l=training
http://www.microsoft.com/downloads/en/d ... 12f59bd428
If you have access to LinkedIn Learning (All SJSU affiliates):
https://www.linkedin.com/learning/learning-office-365-microsoft-365/increase-your-
productivity-with-office-365

Microsoft Office 365 Info and
Tutorials

Microsoft Office 365:

https://www.office.com/
http://www.microsoft.com/mac/
https://support.office.com/en-us/office-training-center?ms.officeurl=training
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3bc6bade-2b14-4530-9a93-c712f59bd428
https://www.linkedin.com/learning/learning-office-365-microsoft-365/increase-your-productivity-with-office-365
https://www.linkedin.com/learning/learning-office-365-microsoft-365/increase-your-productivity-with-office-365


 

Word 2011 and 2016:

1. Open Word, click on File > Preferences... > Save.
2. Change the "Save Word files as" setting to "Word 97-2003 Document" (.doc).
3. Click OK to save the settings.

2019/365:

1. On the File tab, click Save As, and then click Browse.
2. In the Save As dialog box, in the Save as type list, click PowerPoint 97-2003

Document (*.doc).
3. Click Save.

Excel 2011 and 2016:

1. Open Excel, click on File > Preferences... > Compatibility.
2. Change the "Save files in this format" setting to "Excel 97-2003 Workbook (.xls)".
3. Click OK to save the settings.

2019/365:

1. Click File > Export > Change File Type.
2. Under Workbook File Types, double-click Excel 97-2003 Workbook (*.xls).
3. In the Save As popup window, choose a folder location for the workbook.
4. In the File name box, type a new file name (or use the one that’s already there).
5. Click Save.
6. If the Compatibility Checker appears, review any compatibility issues that were found.

PowerPoint 2011 and 2016:

Configure Office to Save in
Compatibility Mode



1. Open PowerPoint, click on File > Preferences... > Save.
2. Change the "Save PowerPoint files as" setting to "PowerPoint 97-2003 Presentation"

(.ppt).
3. Click OK to save the settings.

2019/365:

1. On the File tab, click Save As, and then click Browse.
2. In the Save As dialog box, in the Save as type list, click PowerPoint 97-2003

Presentation (*.ppt).
3. Click Save.



OneDrive is a cloud storage system by Microsoft as part of its suite of Office Online services. You
can sync multiple Windows products together for easy access and automatic backup. Check out
OneDrive's Help Center to learn about OneDrive's other storage capabilities.

How to sync with Windows:
Click on the following link to sync OneDrive on Windows.

How to sync with Mac:
Click on the following link to sync OneDrive on Mac.

How to upload photos automatically on your phone:
Android:
Click on the following link and scroll down to the “Automatically upload photos and videos you take
to OneDrive” section

iOS:
Click on the following link and scroll down to the “Automatically save photos and videos you take to
OneDrive” section

How to create an album:
OneDrive is capable of creating albums for your photos and videos automatically based on the date
they were taken. Click here and scroll down to the “Automatic album creation” section. To create
your own album scroll down to the “Create your own album” section

How to add tags to your photos:
Click here and scroll down to the “Edit or remove a tag” section.

OneDrive Image
Management FAQ

https://onedrive.live.com/about/en-us/
https://support.office.com/en-us/onedrive
https://support.office.com/en-us/article/sync-files-with-the-onedrive-sync-client-in-windows-615391c4-2bd3-4aae-a42a-858262e42a49
https://support.office.com/en-us/article/sync-files-with-the-onedrive-sync-client-on-mac-os-x-d11b9f29-00bb-4172-be39-997da46f913f
https://support.office.com/en-us/article/use-onedrive-on-android-eee1d31c-792d-41d4-8132-f9621b39eb36
https://support.office.com/en-us/article/use-onedrive-on-ios-08d5c5b2-ccc6-40eb-a244-fe3597a3c247
https://support.office.com/en-us/article/organize-and-find-photos-in-onedrive-6a9b0298-f504-4992-af0e-45e2f270afc9
https://support.office.com/en-us/article/organize-and-find-photos-in-onedrive-6a9b0298-f504-4992-af0e-45e2f270afc9


 

Utilizing 2 monitors, and in this case a laptop with a VGA output, you can view all of your slides
along with notes on your laptop screen and only the full screen presentation is seen on the VGA
output (projector). 

NOTE: Before configuring PowerPoint, be sure that your computer is connected to an external
display and that your video settings are configured as "extended desktop" or "dual view" rather
than "mirrored" or "clone".

Here is a link on what Presenter View is all about and how to use it: https://support.office.com/en-
us/articl ... 4736928ee3

Configure the Display Properties:

1. Right click on your desktop and click on Properties
2. Click on the settings tab.
3. Click on the secondary monitor, in this case most of the time it will appear greyed out and

have a 2 on it.
4. Next check Extend my Windows desktop onto this monitor and click OK.

Configure PowerPoint to use Presenter View:

1. Connect your laptop to a projector or other external video device.
2. In PowerPoint, on the Slide Show menu, click Set Up Show.
3. Under Multiple monitors, select the Show Presenter View check box.
4. In the Display slide show on list, click the monitor you want the slide show presentation to

appear on.
5. To start the presentation, click the start presentation icon, or press Shift+F5.

Using PowerPoint's Presenter
View

 

Windows:

 

https://support.office.com/en-us/article/what-is-presenter-view-98f31265-9630-41a7-a3f1-9b4736928ee3
https://support.office.com/en-us/article/what-is-presenter-view-98f31265-9630-41a7-a3f1-9b4736928ee3


1. Connect your laptop to a projector or other external video device.
2. Open System Preferences.
3. Select the Displays System Preference and click "detect displays"
4. Open your PowerPoint presentation and click on: Slideshow > View Presenter Tools.

macOS:



If you will be presenting on a different computer than the one on which it was created or if you wish
to distribute your PowerPoint Presentation, save your PowerPoint in a portable format. This will
insure that images and video in your PowerPoint presentations are saved along with the PowerPoint
file itself and will load properly when played on a different computer:

Office 2003 (Windows):

1. Open the PowerPoint file.
2. Click File > Package for CD...
3. Enter a name for the portable presentation and click the "Copy to Folder..." button.
4. Name the folder, select a location to save and click OK.

More details about saving portable PowerPoint presentations on PowerPoint 2003 are available 
here.

Office 2007 (Windows):

1. Open the PowerPoint file.
2. Click the Office button at the top left of the PowerPoint 2007 screen.
3. Select Publish > Package for CD
4. Enter a name for the portable presentation and click the "Copy to Folder..." button.
5. Name the folder, select a location to save and click OK.

More details about saving portable PowerPoint presentations on PowerPoint 2007 are available 
here.

Office 2010 (Windows):

1. Open the PowerPoint file.

Saving a Portable
PowerPoint Presentation
 

Portable PowerPoint Presentations:

https://www.uwec.edu/kb/article/microsoft-powerpoint-2003-making-presentations-portable/
http://presentationsoft.about.com/od/powerpoint2007/ss/071202package07_7.htm


2. Click the File tab.
3. Click Save & Send, then click Package Presentation for CD.
4. Click the Package for CD button.
5. Enter a name for the portable presentation and click the "Copy to Folder..." button.
6. Name the folder, select a location to save and click Select.
7. When prompted to include linked files, click yes.

More details about saving portable PowerPoint presentations on PowerPoint 2010 are available 
here.

Office 2004 (Mac OS X):

1. Open the PowerPoint file.
2. Click File > Save As... and select "PowerPoint Package" from the "Format" drop-down

menu.
3. The PowerPoint presentation will be saved to a folder with all image and video files. Copy

the entire folder to your flash drive or burn it to a CD in order to view the PowerPoint
presentation on a different computer.

 

Office 2008 (Mac OS X):

1. Open the PowerPoint file.
2. Click File > Save As... and select "PowerPoint Package" from the "Format" drop-down

menu.
NOTE: The PowerPoint presentation will be saved as a .pptx. If the version of Office you
are using is not able to handle .pptx files, you can download and install a file format
converter that will enable older versions of PowerPoint to open files created in the Office

2008. More information can be found here.
3. The PowerPoint presentation will be saved to a folder with all image and video files. Copy

the entire folder to your flash drive or burn it to a CD in order to view the PowerPoint
presentation on a different computer.

 

Office 2011 & Newer (Windows & Mac OS X):

Since PowerPoint 2011, PowerPoint embeds images and video into the presentation by
default when saving, making all recent PowerPoint presentations portable. There is no
longer a need to specify saving the PowerPoint presentation in a portable format.
1. On the File tab, select Save.
2. Do of the following:

To save to your local drive, such as your laptop, a flash drive, CD or DVD drive,
select Computer.

http://office.microsoft.com/en-us/powerpoint-help/package-a-presentation-for-cd-HA010336719.aspx
https://kb.mlml.sjsu.edu/viewtopic.php?f=34&t=269&p=338


To save to a SharePoint Library, select SharePoint.
To save your presentation to a web location, see Save and share a presentation
to OneDrive.

3. Under Save As > Recent Folders, select Browse, pick a path and file folder, and then
name the file.

4. Select Save.

https://support.office.com/en-us/article/save-and-share-a-presentation-to-onedrive-cdbec569-a18f-4bdc-92e8-d07a8ab5eb95
https://support.office.com/en-us/article/save-and-share-a-presentation-to-onedrive-cdbec569-a18f-4bdc-92e8-d07a8ab5eb95


1. Select the Start button, then select Settings > Apps.
2. Choose the program you want to remove, and then select Uninstall.
3. To remove an app you got from Microsoft Store, find it on the Start menu, press and hold

(or right-click) on the app, then select Uninstall.

For more information, go here.

1. Open Finder > Applications.
2. Command +click to select all of the Office for Mac applications.
3. Ctrl+click an application you selected and click Move to Trash.

For more information, go here.

How do I Uninstall Office?
Windows:

macOS:

https://support.office.com/en-us/article/uninstall-office-from-a-pc-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8
https://support.office.com/en-us/article/uninstall-office-for-mac-eefa1199-5b58-43af-8a3d-b73dc1a8cae3


What does this procedure actually do and why am I doing it?

You are essentially testing your Office .plist files to determine if they are the source of the problem
with an Office application. "Testing" a preference file simply refers to removing the preference file
from the default location (~/Library/Preferences/) and verifying that the Office application starts
normally (the Office application will automatically re-create a preference file when it starts if the
preference file does not already exist in the default location. To test a preference file, simply move
the file from the default location to a different folder, for example a folder you create on your
desktop.

Mac OS X only:

1. Quit all Office applications.
2. Navigate to your ~/Library/Preferences/ folder and drag the file(s) listed in the section

below to your desktop. To access the ~/Library/ folder, from Finder, hold the option key
and click the Go menu, then select the Library from the Go menu.
(NOTE: "~" indicates your user home directory. (ie. /Macintosh HD/Users/yourusername/)

3. Move the following files from your Preferences folder to a folder on your Desktop:
~/Library/Preferences/com.microsoft.Word.plist
~/Library/Preferences/com.microsoft.Excel.plist
~/Library/Preferences/com.microsoft.PowerPoint.plist

4. Relaunch the problematic application (Word, Excel or PowerPoint).
The .plist file(s) will be recreated when you do so.

5. If the application starts successfully and is running normally, trash the old file(s). In the
case of the Word Preferences/Settings file, you will have to reset some preferences (and,
for versions earlier than Word 2008, the AutoCorrect settings).

6. If this doesn't fix the issue, quit all Office applications again, move the Office .plist files to
a folder on your Desktop. The Office .plist files are as follows:

~/Library/Preferences/com.microsoft.office.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist

7. Relaunch the problematic application (Word, Excel or PowerPoint).
8. If this procedure doesn't work for you or causes other issues with your office applications,

I recommend that you move the new files to the Trash and drag the original files back to
where they belong. (If you are using Office 2008 or Newer, look for leftover preferences
from earlier versions (see below) and remove them from your preferences folder).

Word, Excel, or PowerPoint
Crashes or Freezes (macOS)



In Office 365/2019, 2016, 2011, or 2008:
~/Library/Preferences/com.microsoft.Word.plist
~/Library/Preferences/com.microsoft.Excel.plist
~/Library/Preferences/com.microsoft.PowerPoint.plist

If testing these files in Office did not fix the problem, then check to see if you have leftover
preferences from Office 2004 or earlier versions. The .plist files for 2004 are listed below.

In Word 2004:
~/Library/Preferences/Microsoft/com.microsoft.Word.prefs.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist
~/Library/Preferences/Microsoft/Office Font Cache

In Excel 2004:
~/Library/Preferences/Microsoft/com.microsoft.Excel.prefs.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist
~/Library/Preferences/Microsoft/Office Font Cache

In PowerPoint 2004:
~/Library/Preferences/Microsoft/com.microsoft.PowerPoint.prefs.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist
~/Library/Preferences/Microsoft/Office Font Cache

In Word X:
~/Library/Preferences/Microsoft/Word Settings
~/Library/Preferences/Microsoft/Microsoft Component Preferences
~/Library/Preferences/Microsoft/Microsoft Office Settings
~/Library/Preferences/Microsoft/Carbon Registration Database
~/Library/Preferences/Microsoft/Office Font Cache



 

When presenting in the seminar room, for recording purposes the best presentation size is
widescreen (16:9).

1. Open PowerPoint.
2. Select the Design Tab.
3. Select Slide Size and click on widescreen (16:9).

Converting your PowerPoint
Presentation to Widescreen
(16:9)



 

Instructions for using the "Transpose" command to manipulate data are located here:

https://support.office.com/en-us/articl ... f862209744

Convert Columns to Rows, or
Rows to Columns using Excel

https://support.office.com/en-us/article/transpose-rotate-data-from-rows-to-columns-or-vice-versa-3419f2e3-beab-4318-aae5-d0f862209744

