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General Software

See the Software Availability page on the IT Website.

Software Availability (link)

https://mlml.sjsu.edu/itech/software/


General Software

Guests and outside groups are able to access and connect to the MLML guest WiFi. The
WiFi network will appear as “moss-guest” under network selections. Click here to learn
how to connect to the MLML WiFi.

Volunteers are able to access and connect to the MLML WiFi. The WiFi network will appear
as “moss” or “eduroam” under network selections. Click here to learn how to connect to
the MLML WiFi. Eduroam connectivity requires California State University credentials, click
here to learn more.

Volunteers are provided MLML user accounts after their MLML Supervisor submits the
appropriate paperwork. Your MLML username is composed of the first initial of your first
name followed by your last name (i.e. bsimpson for Bart Simpson). Your MLML password
may be different from your gmail password. If you have forgotten your MLML password,
please submit an IT Helpdesk Ticket.

Volunteers must demonstrate a need to use the VPN server. Authorized faculty or
research affiliates must provide approval. Click here to learn how to access the MLML
network using VPN.

Service Level Agreements
Public/Outside Groups:
Wifi

Volunteers
Wifi

MLML Account

VPN

Students
WiFi

https://mlml.sjsu.edu/itech/network/
https://mlml.sjsu.edu/itech/network/
https://mlml.sjsu.edu/itech/network/
https://mlml.sjsu.edu/itech/network/
https://helpdesk.mlml.calstate.edu
https://kb.mlml.sjsu.edu/books/network-services/page/access-the-mlml-network-using-vpn


Students are able to access and connect to the MLML WiFi. The WiFi network will appear
as “moss” or “eduroam” under network selections. Click here to learn how to connect to
the MLML WiFi. Eduroam connectivity requires California State University credentials, click
here to learn more. 

Students are provided MLML user accounts. Your MLML username is composed of the first
initial of your first name followed by your last name (i.e. bsimpson for Bart Simpson). Your
MLML password may be different from your gmail password. If you have forgotten your
MLML password, please submit an IT Helpdesk Ticket.
User accounts at Moss Landing Marine Laboratories are required to authenticate faculty,
staff, students, and visiting scientists and to enable access to services. Click here to view
provided services requiring user authentication.

Students are granted SJSU email accounts (i.e. firstname.lastname@sjsu.edu). If you have
forgotten your SJSU Gmail account password, click here.

Students must demonstrate a need to use the VPN server. Authorized faculty or research
affiliates must provide approval. Click here to learn how to access the MLML network
using VPN.

To view a list of hardware available for checkout click here. If you would like to checkout
an item on the list please submit an IT Helpdesk Ticket under the Request Type “Tech
checkout.” Once the checkout is approved, visit the IT Help Desk cubicle (Admin offices
Room 200) any time from 9-5 on M-F to pickup or return the item. 
To view a list of hardware available in individual classrooms click here.

For a list of available software click here. Submit an IT Helpdesk Ticket if you would like to
request a program listed in the software section or if you need assistance with an
installation.

Students are authorized to print from the Library Copier. 

MLML Account

Email

VPN

Hardware

Software

Network Printing

https://mlml.sjsu.edu/itech/network/
https://mlml.sjsu.edu/itech/network/
https://mlml.sjsu.edu/itech/network/
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https://kb.mlml.sjsu.edu/books/network-services/page/access-the-mlml-network-using-vpn
https://mlml.populiweb.com/library/catalog/index.php
https://kb.mlml.sjsu.edu/books/help-desk-tech-resources/page/classroom-technology-guide
https://mlml.sjsu.edu/itech/software/


The procedure for installing the Konica Minolta Copier as a printer will depend on whether
you own a Windows or Mac OS X system. General printer installation may be found here.
A list of MLML network DNS names could be found here.

MS Students are able to access and connect to the MLML WiFi. The WiFi network will
appear as “moss” or “eduroam” under network selections. Click here to learn how to
connect to the MLML WiFi. Eduroam connectivity requires California State University
credentials, click here to learn more. 

MS Students are provided MLML user accounts. Your MLML username is composed of the
first initial of your first name followed by your last name (i.e. bsimpson for Bart Simpson).
Your MLML password may be different from your gmail password. If you have forgotten
your MLML password, please submit an IT Helpdesk Ticket.
User accounts at Moss Landing Marine Laboratories are required to authenticate faculty,
staff, students, and visiting scientists and to enable access to services. Click here to view
provided services requiring user authentication.

Students are granted SJSU email accounts (i.e. firstname.lastname@sjsu.edu). If you have
forgotten your SJSU Gmail account password, click here.

MS Students must demonstrate a need to use the VPN server. Authorized faculty or
research affiliates must provide approval. Click here to learn how to access the MLML
network using VPN.

To view a list of hardware available for checkout click here. If you would like to checkout
an item on the list please submit an IT Helpdesk Ticket under the Request Type “Tech
checkout.” Once the checkout is approved, visit the IT Help Desk cubicle (Admin offices
Room 200) any time from 9-5 on M-F to pickup or return the item. 
To view a list of hardware available in individual classrooms click here.

MS Students
WiFi

MLML Account

Email

VPN

Hardware
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https://kb.mlml.sjsu.edu/books/printing-scanning/page/mlml-network-printer-dns-names
https://mlml.sjsu.edu/itech/network/
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mailto:MLMLUser@mlml.calstate.edu
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For a list of available software click here. Submit an IT Help Desk ticket if you would like to
request a program listed in the software section or if you need assistance with an
installation.

MS Students are authorized to print from the Library Copier. 
The procedure for installing the Konica Minolta copier as a printer will depend on whether
you own a Windows or Mac OS X system. General printer installation may be found here.
A list of MLML network DNS names could be found here.

Faculty are able to access and connect to the MLML WiFi. The WiFi network will appear as
“moss” or “eduroam” under network selections. Click here to learn how to connect to
the MLML WiFi. Eduroam connectivity requires California State University credentials, click
here to learn more. 

Faculty are provided MLML user accounts. Your MLML username is composed of the first
initial of your first name followed by your last name (i.e. bsimpson for Bart Simpson). Your
MLML password may be different from your gmail password. If you have forgotten your
MLML password, please submit an IT Helpdesk Ticket.
Faculty at Moss Landing Marine Laboratories are required to authenticate faculty, staff,
students, and visiting scientists and to enable access to services. Click here to view
provided services requiring user authentication.

Faculty are granted SJSU email accounts (i.e. firstname.lastname@sjsu.edu). If you have
forgotten your SJSU Gmail account password, click here.

Faculty must demonstrate a need to use the VPN server. Authorized faculty or research
affiliates must provide approval. Click here to learn how to access the MLML network
using VPN.

Software

Network Printing

Faculty
WiFi

MLML Account

Email

VPN
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To view a list of hardware available for checkout click here. If you would like to checkout
an item on the list please submit an IT Helpdesk Ticket under the Request Type “Tech
checkout.” Once the checkout is approved, visit the IT Help Desk cubicle (Admin offices
Room 200) any time from 9-5 on M-F to pickup or return the item. 
To view a list of hardware available in individual classrooms click here.

For a list of available software click here. Submit an IT Helpdesk Ticket if you would like to
request a program listed in the software section or if you need assistance with an
installation.

Faculty are authorized to print from the Admin Copier, Faculty Printer, or Library Printer. 
The procedure for installing the Konica Minolta Copier as a printer will depend on whether
you own a Windows or Mac OS X system. General printer installation may be found here.
A list of MLML network DNS names could be found here.

Staff are able to access and connect to the MLML WiFi. The WiFi network will appear as “
moss” or “eduroam” under network selections. Click here to learn how to connect to the
MLML WiFi. Eduroam connectivity requires California State University credentials, click
here to learn more. 

Staff are provided MLML user accounts. Your MLML username is composed of the first
initial of your first name followed by your last name (i.e. bsimpson for Bart Simpson). Your
MLML password may be different from your gmail password. If you have forgotten your
MLML password, please submit an IT Helpdesk Ticket.
User accounts at Moss Landing Marine Laboratories are required to authenticate faculty,
staff, students, and visiting scientists and to enable access to services. Click here to view
provided services requiring user authentication.
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Staff are granted SJSU email accounts (i.e. firstname.lastname@sjsu.edu). If you have
forgotten your SJSU Gmail account password, click here.

Staff must demonstrate a need to use the VPN server. Authorized faculty or research
affiliates must provide approval. Click here to learn how to access the MLML network
using VPN.

Staff are provided a computer during the on-boarding process. Staff may request
additional computers by submitting an IT Helpdesk Ticket.

To view a list of hardware available for checkout click here. If you would like to checkout
an item on the list please submit an IT Helpdesk Ticket under the Request Type “Tech
checkout.” Once the checkout is approved, visit the IT Help Desk cubicle (Admin offices
Room 200) any time from 9-5 on M-F to pickup or return the item. 
To view a list of hardware available in individual classrooms click here.

For a list of available software click here. Submit an IT Helpdesk Ticket if you would like to
request a program listed in the software section or if you need assistance with an
installation.

Staff are authorized to print from the Admin or Library Printer. 
The procedure for installing the Konica Minolta Copier as a printer will depend on whether
you own a Windows or Mac OS X system. General printer installation may be found here.
A list of MLML network DNS names could be found here.
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General Software

 

The SJSU Spartan Store has a wide selection of software available to staff and faculty at
significantly reduced prices.

1. Go to https://spartanshops.onthehub.com/
2. Click Register in the upper right corner of the page.
3. Enter your @sjsu.edu email address.

NOTE: If you don't have access to/don't know your SJSU email address, please check the 

SJSU Services Introduction post.
4. Enter your first name, your last name, and choose a password. Your SJSU email address

should already be filled in. This will be your username when using the Spartan Store.
5. Under Proof of Eligibility, there is a Group of which you are a member dropdown

list. Select the option that reflects you.
6. Complete the captcha and click Register.
7. Find the most accurate options for the Which department/field of study do you work

in, Which operating system do you use more often, and Where did you hear
about us dropdowns, then click Save.

8. A verification email will be sent to your SJSU email address. Follow the instructions in that
email and you'll be able to start using the store.

How to Register for &
Purchase Software from the
Spartan Store

 

Register

 

Purchase

https://spartanshops.onthehub.com/
https://kb.mlml.sjsu.edu/books/network-services/page/sjsu-services-introduction


NOTE: Once you complete your purchase, save a copy of any product keys you receive in a safe
place. The Spartan Store will not hold onto them for you forever. If you lose your product key you
may have to buy the software again.

1. Go to https://spartanshops.onthehub.com/ and login with your SJSU email address.
2. Find the software you want by navigating the site or by using the Product Search bar.

Navigation
1. Make sure you are on the Faculty/Staff tab if that matches your description.

This will display the full list of software available to you.
2. Use the tabs to find the product you need. For instance, if you're looking for

Microsoft Office or Microsoft Windows, click the Microsoft tab.
NOTE: The Show recent versions only checkbox sometimes hides software
that it shouldn't, such as the Windows versions of Microsoft Office. Leave this
unchecked or you risk the website hiding the software you're looking for.

3. Click the icon for the software you want, then click Add to cart.
Search
1. Simply type the software you want into the Product Search bar and hit Enter.

Be non-specific - the base product name (such as "office") without any version
numbers is best.

2. Scroll to the software version you want, select it, and click Add to cart.
3. Open your Shopping Cart located on the upper right side of the page. If everything looks

correct to you, click Check Out.
4. Follow the prompts and enter your billing information to complete your order.

https://spartanshops.onthehub.com/


General Software

1. Open Firefox.
2. Select Library (stacked books icon) > Bookmarks > Show all Bookmarks.
3. In the Library window, click Import and Backup >Import Data from Another Browser…..

The Import Wizard will open.
4. Select the browser that contains the bookmarks or other data that you want to use in

Firefox and then continue to the next screens to make your selections and complete the
import.

5. If the Import Wizard does not list your other browser, you can still import bookmarks from
another browser but you will need to first export and save those bookmarks as an HTML
file. Visit the support site for your other browser if you need help with that.

For more information on importing bookmarks into Firefox from other browsers click here.

To learn how to import bookmarks into Firefox from another Firefox installation or profile, see
Recovering important data from an old profile.

To learn how to import bookmarks into Firefox from an HTML file click here.

1. Open Firefox.
2. Select Library (stacked books icon) > Bookmarks > Show all Bookmarks.
3. From the toolbar on the Library window, click Import and Backup > Export Bookmarks to

HTML...
4. In the Export Bookmarks File window that opens, choose a location to save the file, which

is named bookmarks.html by default. The desktop is usually a good spot, but any place
that is easy to remember will work.

Import and export Firefox
bookmarks
Import bookmarks into Firefox:
(Restore backed-up or migrated bookmarks)

Export bookmarks out of Firefox:
(Back-up or migrate your bookmarks)

https://support.mozilla.org/en-US/kb/import-bookmarks-data-another-browser
https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
https://support.mozilla.org/en-US/kb/import-bookmarks-html-file


5. Click the Save button. The Export Bookmarks File window will close.
6. Close the Library window.

For more information click here.

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer


General Software

Web browser extensions are popular add-ons that can aid in your day-to-day online activities and
improve security. There are a lot to choose from, but simplicity is key. Only download extensions
that you know you will use and benefit from on a regular basis. IMPORTANT NOTE: Always
download from a reputable source and check reviews before downloading to stay safe.

1. Visit the Google Chrome Extension Store
2. Search for the extension you want or browse through the selection
3. Click on the extension you wish to add
4. Click Add to Chrome
5. The extension will now appear in the top-right corner of the browser window

1. Open Safari
2. Choose Safari > Safari Extensions
3. Search for the extension you want or browse through the selection
4. Click GET > INSTALL
5. The extension will now appear to the left of the search bar

1. Open Firefox
2. Click on settings in the top-right corner
3. Click Add-ons > Get Add-ons
4. Search for the extension you want or browse through the selection
5. Click Install
6. The extension will now appear in the top-right corner of the browser window

Installing Web Browser
Extensions: Google Chrome,
Safari, FireFox

Google Chrome:

Safari:

Firefox:

Popular Extensions We Endorse

https://chrome.google.com/webstore/category/extensions?hl=en


uBlock Origin - adblocker
LastPass - password manager
Session Buddy - tab manager
Mendeley Web Importer - citation manager
Grammarly - your own personal editor
Honey - online discounts

https://chrome.google.com/webstore/detail/ublock-origin/cjpalhdlnbpafiamejdnhcphjbkeiagm?hl=en
https://chrome.google.com/webstore/detail/lastpass-free-password-ma/hdokiejnpimakedhajhdlcegeplioahd?hl=en-US
https://chrome.google.com/webstore/detail/session-buddy/edacconmaakjimmfgnblocblbcdcpbko?hl=en
https://chrome.google.com/webstore/detail/mendeley-web-importer/dagcmkpagjlhakfdhnbomgmjdpkdklff?hl=en
https://chrome.google.com/webstore/detail/grammarly-for-chrome/kbfnbcaeplbcioakkpcpgfkobkghlhen?hl=en
https://chrome.google.com/webstore/detail/honey/bmnlcjabgnpnenekpadlanbbkooimhnj?hl=en


General Software

Recommended Software
(link)
Check out some software we recommend on our Recommended
Software Page

https://mlml.sjsu.edu/its/recommended-software/
https://mlml.sjsu.edu/its/recommended-software/


General Software

There are times when you need to use a certain software application or device but do not have
physical access. Instead, you can remotely access a device at MLML that has the software you
need or computing capabilities. Below are the instructions on how to gain software & computing
access remotely.

 

Identify the application/computing that you need and research it to know what exactly it is
you're looking for:

Version/Year
Model
Specs (CPU, Storage)

Pinpoint exactly what you'll be using the application/device for

 

Once you know what you need, we can help you get access to it. Submit an IT Helpdesk Ticket with
the information you uncovered from Step 1. Please do the research before submitting an IT
Helpdesk Ticket so we know exactly what it is you are trying to accomplish.

 

Once you have the go-ahead from the IT Department, setup access to the MLML network using
VPN. You will need to be connected to the MLML network to access a device remotely.

Remote Software &
Computer Access Procedure

STEP 1: Identify Needs

STEP 2: Submit an IT Helpdesk Ticket

STEP 3: Access MLML VPN

Access the MLML Network using VPN Instructions

https://helpdesk.mlml.calstate.edu/
https://kb.mlml.sjsu.edu/books/network-services/page/access-the-mlml-network-using-vpn


 

NOTE: The following instructions are to connect to a Windows desktop computer from Windows or
macOS.

IMPORTANT: You will need to configure the Windows computer to which you are connecting to
allow Remote Desktop connections. Refer to the Troubleshooting section below to enable Remote
Desktop connections

Launch Remote Desktop Connection

Start Menu > search for "Remote Desktop Connection" or Start Menu > Windows
Accessories folder

In the Computer field type the name or IP address of the device you're connecting to
Select Show Options
Enter the username of the account you'll use to login

Select "Allow me to save credentials" to save the credentials so you don't have to
enter them each time you access this device

Select Connect

STEP 4: Launch Remote Desktop

Windows:



Enter the password associated with the username you used into the window that pops-up
Again you can select "Remember me" so you do not have to enter the password
each time

Click OK 

You may receive a message saying that the identity of the remote computer cannot be
verified. Check the box for "Don't ask me again for connections to this computer"
and click Yes
You should now be connected
For more information on how to use Remote Desktop Connection go to this link "How to
Use Microsoft's Remote Desktop Connection"

Download "Microsoft Remote Desktop" from the Mac app store
Open Microsoft Remote Desktop
Select "Add PC" in the center when the app opens

Mac:

https://www.pcmag.com/how-to/how-to-use-microsofts-remote-desktop-connection
https://www.pcmag.com/how-to/how-to-use-microsofts-remote-desktop-connection
https://apps.apple.com/us/app/microsoft-remote-desktop-10/id1295203466?mt=12
https://apps.apple.com/us/app/microsoft-remote-desktop-10/id1295203466?mt=12


Fill in the fields:
PC name is the IP address
User account: either "Ask when required" or if you will be using this account often
use "Add User Account..."

 
For Add User Account: enter the username of account you're accessing & the
associated password
Press Add



Friendly Name: what you want to call the connection - optional
Group: Where you want to save this connection
Gateway: no gateway configured
For all other tabs (Display, Devices & Audio, Folders): these settings are your
preference - you can stick with the standard and go from there

The Folders tab allows you to share files and folders between the devices
For more information about these other tabs visit "How to remote access
Windows 10 from Mac"

Click Add
To begin a session with that remote desktop just simply double-click it

To edit it, select the pen in the top right corner of the desktop icon
A pop-up should show with "Enter Your User Account" to enter your username and
password

You may see a prompt about your connection (see below), select Continue

https://www.digitalcitizen.life/connecting-remotely-windows-desktop-mac-os-x
https://www.digitalcitizen.life/connecting-remotely-windows-desktop-mac-os-x


For more information about accessing using Mac, go to the link "How to remote access
Windows 10 from Mac"

 

If you followed all steps and are not able to connect to the remote desktop, it might be that the
desktop you are trying to connect to is not setup with remote desktop. If you or someone else can
access the desktop physically, use the following instructions to setup the device:

Login to the account you will be remote accessing
Open Settings > System > Remote Desktop
Turn on the switch next to "Enable Remote Desktop"
Select Confirm

Troubleshooting:

https://www.digitalcitizen.life/connecting-remotely-windows-desktop-mac-os-x
https://www.digitalcitizen.life/connecting-remotely-windows-desktop-mac-os-x


Make sure "Keep my PC awake for connections when it is plugged in" and "Make my PC
discoverable on private networks to enable automatic connection from a remote device"
are checked
Select Advanced Settings



Check the box next to "Require computers to use Network Level Authentication (NLA) to
connect" 

For more information: How to Use Microsoft's Remote Desktop Connection or How to remote access
Windows 10 from Mac

https://www.pcmag.com/how-to/how-to-use-microsofts-remote-desktop-connection
https://www.digitalcitizen.life/connecting-remotely-windows-desktop-mac-os-x
https://www.digitalcitizen.life/connecting-remotely-windows-desktop-mac-os-x


General Software

General Software
Information Reference Page
(Link)
Follow this link to our Software landing page to find helpful links about
software available to you.

https://mlml.sjsu.edu/its/software-landing/
https://mlml.sjsu.edu/its/software-landing/


Google Drive, One Drive, etc...

Cloud-based Software



Cloud-based Software

WHY Google Drive/ OneDrive? Some of the BENEFITS include:

Platform non-specific (Windows, Mac, Linux, Mobile, iOs, etc)
Browser non-specific (Chrome*, Firefox,, Safari, Opera) *recommended
Web-based allows for anytime, anywhere usage as long as internet-connected
Automatically updates
Automatically saves
Allows COLLABORATION
Provides cloud-based sharing for ANY file type (unlimited)

1. Download and Install Google Drive: https://www.google.com/drive/download/

After the download is complete, locate the downloaded file (usually in your Downloads
folder) named something like "GoogleDriveSetup.exe" and double-click on it.
A setup wizard will appear. Follow the prompts to install Google Drive on your computer.
Once installed, locate the Google Drive icon on your desktop or in the Start menu and
double-click on it to open.
Sign in with your SJSU credentials.

2. Backing Up Your Computer Files:

Click on the File Explorer icon in the taskbar (it looks like a folder).
Navigate to the files and folders you want to back up in File Explorer.
Click and hold on the file or folder you want to back up, then drag it over to the Google
Drive folder in the left sidebar of the File Explorer window
Release the mouse button to drop the file or folder into Google Drive.
Wait for Sync -Google Drive will automatically start syncing the files and folders you've
added. You'll see a status icon in the system tray showing the progress.
Once synced, you can access your files from any device by logging in to your Google Drive
account.

OPTIONAL BUT RECOMMENDED

3. Set Up Automatic Backup:

Cloud Backup - Google Drive

Installing and Backing up FILES on Google Drive:
Windows Computer

https://www.google.com/drive/download/


Right-click on the Google Drive icon in the application panel and select "Preferences."
In the Preferences window, navigate to the "Sync" tab and check the box next to "Sync My
Drive to this computer."
Adjust any other settings as desired and click "Apply" or "OK" to save the changes.

1. Download and Install Google Drive: https://www.google.com/drive/download/

After the download is complete, locate the downloaded file (usually in your Downloads
folder) named something like "InstallGoogleDrive.dmg" and double-click on it.
A new window will open with the Google Drive icon. Drag the icon into the Applications
folder icon to install Google Drive.
A setup wizard will appear. Follow the prompts to install Google Drive on your computer.
Once installed, locate the Google Drive icon on your desktop or in the Start menu and
double-click on it to open.
Sign in with your SJSU credentials.

2. Backing Up Your Computer Files:

Click on the Finder icon in the Dock (it looks like a blue and white face).
Navigate to the files and folders you want to back up in Finder.
Click and hold on the file or folder you want to back up, then drag it over to the Google
Drive icon in the sidebar of the Finder window.
Release the mouse button to drop the file or folder into Google Drive.
Wait for Sync -Google Drive will automatically start syncing the files and folders you've
added. You'll see a status icon in the system tray showing the progress.
Once synced, you can access your files from any device by logging in to your Google Drive
account.

OPTIONAL BUT RECOMMENDED

3. Set Up Automatic Backup

Open Google Drive preferences by clicking on the Google Drive icon in the menu bar and
selecting "Preferences."
In the Preferences window, navigate to the "Settings" tab and check the box next to "Sync
My Drive to this computer."
Adjust any other settings as desired and close the Preferences window.

It’s highly recommended to periodically check your Google Drive to ensure all desired
files are backed up and up to date.

Installing and Backing up FILES on Google Drive:
Mac OS X

https://www.google.com/drive/download/


That's it! You've successfully downloaded and installed Google Drive on your Windows/
Mac OS X computer and backed up your important files to the cloud.

Additionally, Google maintains an active support site: https://support.google.com/drive/

And then, there’s always YouTube! 

Need more help?  >>>> Submit a help ticket! We’re here to help you. 

https://support.google.com/drive/
https://isupport.sjsu.edu/mlml/Dashboard


Cloud-based Software

If you are using a SJSU-provided computer OneDrive is pre-installed. You can find it in the Start
Menu or by searching for it. Otherwise, follow the instructions below:

1. Download and Install OneDrive: https://drive.live.com/

Sign in with SJSU credentials or hit the download tab. (Top center)
After the download is complete, locate the downloaded file (usually in your Downloads
folder) named something like "OneDrive.exe" and double-click on it.
A setup wizard will appear. Follow the prompts to install OneDrive on your computer.
Once installed, locate the OneDrive icon on your desktop or in the Start menu and double-
click on it to open.
Sign in with your SJSU credentials.

2. Backing Up Your Computer Files:

Automatic Backup- Once logged in, OneDrive will ask you which folders you want to sync
to your computer. Select the ones you want to back up and sync across devices, ie.,
Documents, Pictures, Desktop, etc.
Manual Backup- Simply move or copy files you want to back up into the OneDrive folder
on your computer. These files will sync to the cloud automatically.
The synching process will start immediately. You will see a status check icon in the system
tray showing the progress.
Once synced, you can access your files from any device by logging in to your SJSU
Microsoft OneDrive account.

1. Download and Install OneDrive: https://drive.live.com/ or Download From the Mac App
Store.

Cloud Backup - Microsoft
OneDrive
Installing and Backing up FILES on Microsoft
OneDrive: Windows Computer

Installing and Backing up FILES on Microsoft
OneDrive: MAC OS X

https://drive.live.com/%5C
https://drive.live.com/%5C


Sign in with SJSU credentials or hit the download tab. (Top center)
After the download is complete, locate the downloaded file (usually in your Downloads
folder) named something like "OneDrive.dmg" and double-click on it.
A setup wizard will appear. Follow the prompts to install OneDrive on your computer.
Once installed, locate the OneDrive icon on your Application Folder and double-click on it
to open.
Sign in with your SJSU credentials.

 2. Backing Up Your Computer Files:

Automatic Backup- Once logged in, OneDrive will ask you which folders you want to sync
to your computer. Select the ones you want to back up and sync across devices, ie.,
Documents, Pictures, Desktop, etc.
Manual Backup- Simply move or copy files you want to backup into the OneDrive folder on
your computer. These files will sync to the cloud automatically.
The synching process will start immediately. You will see a status check icon in the system
tray showing the progress.
Once synced, you can access your files from any device by logging in to your SJSU
Microsoft OneDrive account.

You have now installed OneDrive, set it up, and backed up your computer files to the cloud.

Need more help?  >>>> Submit a help ticket! We’re here to help you. 

https://isupport.sjsu.edu/mlml/Dashboard


Cloud-based Software

 

1. Create a folder on Google Drive (web interface) which you would like to have synced with
your Dropbox files. 

2. Download and Install Google Backup and Sync
3. Click on the Google Backup and Sync tray icon or quick launch icon (looks like a cloud with

an up arrow)
4. A setup window will pop up
5. Sign in to your MLML Google Account
6. In the “My Laptop” section (May say “My Desktop” if you have a Desktop or “My

Macbook”, etc.), uncheck all boxes.
7. In the Google Drive section, check the folder in your Google Drive you created earlier for

your Dropbox files. It will also sync everything not in a folder (In your Google Drive base
folder).
1. If you would like to sync your entire Google Drive, check "Sync My Drive to this

computer" at the top.
8. Move your Dropbox files into the folder with the name that you created earlier, within the

Google Drive folder on your computer.
9. Finish up and let your files sync (this will take awhile)

10. You can access these settings later by clicking on the Google Backup And Sync icon,
clicking the three vertical dots icon, and clicking preferences

Migrating from Dropbox to
Google Backup and Sync



Find information about different operating systems.

Operating Systems



Operating Systems

IT highly recommends using either macOS or Windows 10 operating systems. Keeping your
operating system up to date with the most current upgrades available will allow your system to run
at optimal performance and security levels.

Apple provides free upgrades to newer operating systems when they become available.

Apple's newest version of macOS
Compatible with these computers: https://support.apple.com/en-us/HT211238

Once you have installed the latest operating system available, keep it up-to-date by enabling
automatic updates by following the instructions here.

Microsoft's newest operating systems must be purchased before being installed.

Microsoft's newest windows operating system
Windows 10 is compatible with most PCs

Once you have installed the latest operating system available, keep it up-to-date by enabling
automatic updates by following the instructions here.

Recommended Operating
Systems: MacOS & Windows

macOS

Big Sur

Windows

Windows 10

https://support.apple.com/en-us/HT211238
https://support.apple.com/en-us/HT201541
https://support.microsoft.com/en-us/help/4027667/windows-10-update
https://www.apple.com/macos/big-sur/
https://www.microsoft.com/en-us/store/b/windows?activetab=tab:shopwindows10


Microsoft no longer provides support for Windows 7. If you have any computers that are
still running Windows 7, contact IT as soon as possible to be upgraded to Windows 10.
If you have a computer that must continue running Windows 7 (for hardware or software
compatibility reasons), it must be disconnected from the MLML network and the internet
at all times.

Windows 7

https://www.microsoft.com/en-us/windowsforbusiness/end-of-windows-7-support


Operating Systems

NOTE: For image management, see our Image Management, Search, & Use Best Practices Page.

Both Disk Inventory X and WinDirStat show the sizes of files and folders on your drive in a
graphical tree map and in a list
For both programs, DO NOT delete any files in Windows Directory or Program Files
Directory
Recommended that you delete files only in your Users Directory

WinDirStat - This is a program that may be used to analyze and manage hard drive disk space on
Windows. This programs shows which folders, file types, and files are taking up the most space
(e.g. ZIP, EXE, JPEG, etc.). Make sure you do not delete any important system files.

Disk Inventory X - This is a program that may be used to analyze and manage hard drive disk
space on MacOS . This programs shows which folders, file types, and files are taking up the most
space (e.g. MP3, ZIP, JPEG, etc.). Delete files by selecting the file and then click “Move To
Trash”. Make sure you do not delete any important system files.

If error message “‘Disk Inventory X’ can’t be opened because it is from an
unidentified developer”  is received, follow these instructions.

 

 

Computer Storage
Management
 

Disk Space Analyzers

Windows

macOS

Determine Disk Use with Analyzers:
Windows

https://kb.mlml.sjsu.edu/books/wordpress/page/image-management-search-usage
https://ninite.com/
https://download.cnet.com/Disk-Inventory-X/3000-2248_4-47967.html
https://support.apple.com/kb/PH25088?locale=en_US


WinDirStat may be used to scan your entire system and shows which folders, file types,
and files are using up the most space.
1. Run WinDirStat
2. If already downloaded, search for the application in your Start Menu
3. Select the Drive you would like to analyze
4. Click OK - the analyzing process will commence
5. Below is what the results will look like, each color corresponds to a file or folder, and

the size is equivalent to the percentage it takes up on your disk. You can see the
file/folder name in the bottom of the window when you scroll over the section.

 

6. Right-Click a file/folder on the list or in the graphical tree to either “Move to Recycle
Bin” or “Reveal in Folder”. The latter will allow you to select specific files in a folder
to delete.

Disk Inventory X will provide a list of files taking up the most space. Delete files that you
no longer need that are clogging up your disk.
1. Run Disk Inventory X as an administrator

If Disk Inventory X installed previously, click Command + Space and type
“Disk Inventory X” then Enter

2. Select which Drive you’d like to analyze
3. Click “Open Volume” - the program will start analyzing the Drive

4. Below is an example of what your results will look like  

5. The “Statistics” tab will show you which apps and files are taking up the most space
6. Right-Click a file/folder on the list or in the graphical tree to either “Move to Trash”

or “Reveal in Finder”. The latter will allow you to select specific files in a folder to
delete.

For more tips on steps you can take to clear space, follow procedures listed on MacPaw.

 

Start with cleaning up applications, files, photos, etc. that you no longer need on your
computer. Empty your Trash/Recycling Bin on your computer.

1. Open Windows Explorer
2. Right-click on C: drive and select Properties

macOS

Free-Up Disk Space

Windows

https://macpaw.com/how-to/startup-disk-full-on-mac-os-x


3. Select Disk Cleanup
This program analyzes your hard drive and identifies files that are no longer of any
use. After browsing the results, you can remove the unnecessary files

4. Once Disk Cleanup has finished running, review files it found that are no longer of use<
Files to get rid of: temporary files, recycle bin, temporary internet files, and windows
update cleanup files
DO NOT get rid of Windows ESD Installation Files
All other files should be reviewed by you

Here’s a guide on how to use Disk Cleanup safely and effectively from
HowToGeek.

5. Delete files and uninstall programs on your own:
Here’s another good guide from HowToGeek for more general disk space cleanup.
Good places to look for large sets of old files to delete:
1. Downloads folder: Programs you’ve downloaded are generally installed, and

then these installer files just end up wasting lots of space.
2. Pictures / Videos folder: If there’s anything you don’t want any more. (Videos

especially can take up tons of space)
3. Documents folder: These shouldn’t take up lots of space, but cleaning up old

things you have no need for is good practice.
4. Periodically: Go to Control Panel > View By Category > Uninstall a Program,

and uninstall any old programs you no longer use.

Deleting Temporary Files - Temporary files, such as “cab_” are found on your hard
drive. These are reminiscent of Windows Update; deleting these files may free up some
space on your hard drive.
To delete “cab_” files:
1. Right click on the Windows icon.
2. Go to File Explorer → This PC > OS: C in left sidebar
3. Open Windows folder → Temp folder → Continue
4. Scroll down to the files beginning with "cab_"
5. Delete these “cab_” files
For more tips on how to clear disk space, go to Microsoft Disk Cleanup.

Though there are no “Disk Cleanup” equivalents for MacOS, here are some tips on how to
manage and free-up storage space from Apple Support

macOS

https://www.howtogeek.com/266337/what-should-i-remove-in-disk-cleanup-on-windows/
https://www.howtogeek.com/125923/7-ways-to-free-up-hard-disk-space-on-windows/
https://support.apple.com/en-us/HT206996
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macOS

 

This dialog shows you basic information about the manufacture date and hardware of your
Mac.
Click the Apple icon at the top left of the screen on the menu bar.
Click About This Mac.
The dialog window with basic system information will pop up

 Click the System Report button for more detailed information for the advanced user.

System-Information.png

Similar to Task Manager for PC, Activity Monitor displays every program running on your
Mac. You can manage these running programs and identify how they are affecting your
Mac’s performance.
For more information visit Activity Monitor Support.

MacActivityMon.png

 

Computer Performance

macOS is Apple’s operating system for all Mac devices. For more information about macOS visit the  macOS Apple Page.

About This Mac

 

Activity Monitor

Uninstall Unnecessary Applications

https://kb.mlml.sjsu.edu/uploads/images/gallery/2019-02-Feb/System-Information.png
https://support.apple.com/en-us/HT201464
https://kb.mlml.sjsu.edu/uploads/images/gallery/2019-02-Feb/MacActivityMon.png
https://www.apple.com/lae/macos/what-is/


One simple way to clear disk space and keep your computer running smoothly is to
uninstall applications you don’t need or aren’t using.
NOTE: Make sure you know what the application function is before you delete it, some
applications are key to keeping your computer functioning properly.
Find the list of applications: Open Finder → Applications (left side panel)
How to Uninstall Applications on Mac

 

 

Windows also has a basic system information dialog, similar to About This Mac (OS
Version, Processor, Memory, 32/64bit info)
Right click the This PC Icon on your Desktop and Click Properties.

If it isn't there, search "This PC" in the Search Box on your Taskbar.
This system information dialog should pop up

WinSysInfo.png

For more detailed and advanced info, download a third-party system info utility program
like CPU-Z.

Similar to Activity Monitor for Mac, Task Manager displays every program running on your
computer. You can manage these open programs and identify how they are affecting your
computer’s performance.
You can access the Task Manager by pressing Ctrl-Alt-Delete (press all three keys at
once). Once the screen changes color and a menu pops up, click Task Manager.
For more information visit About Task Manager.

Windows

Windows is Microsoft’s operating system for PCs. For more information about Windows visit the  Microsoft Windows Page.

System Information

 

Task Manager

https://support.apple.com/kb/ph25083?locale=en_US
https://kb.mlml.sjsu.edu/uploads/images/gallery/2019-02-Feb/WinSysInfo.png
https://www.cpuid.com/softwares/cpu-z.html
https://www.pcworld.com/article/241693/how_to_use_task_manager.html
https://www.microsoft.com/en-us/windows/features


The Resource (and Performance) Monitor in Windows allows the user to monitor CPU and
memory usage, and disk and network activity in real time. It’s a great resource if your
computer or your software is running slow and you’d like to see what program is causing
the slowdown.
You can access the Resource Monitor by pressing Ctrl-Alt-Delete (press all three keys at
once). Once the screen changes color and a menu pops up, click Task Manager. The
Resource Monitor is a tab, Performance, within the Task Manager window.

 

Resource Monitor



 

 

There is a more detailed Resource Monitor within the Performance tab. At the bottom of
the dialog window, there is a button Open Resource Monitor, with a speedometer icon.
Click on this for a resource monitor where you can find details on which programs are
eating up resources.
For more information visit PC World Resource Monitor.

https://www.pcworld.com/article/241677/how_to_use_resource_monitor.html


Log files such as security changes, administrative files, application files, etc. are all
compiled for viewing in the Event Viewer. It can be very helpful in locating a source of a
problem if your computer starts to have issues.
For more information visit How to Use Event Viewer.
To use Event Viewer to detect problems in your PC visit Microsoft Support - Event Viewer.

 

 

Event Viewer

http://www.dummies.com/computers/operating-systems/windows-10/how-to-use-event-viewer-in-windows-10/
https://support.microsoft.com/en-us/help/302542/how-to-diagnose-system-problems-with-event-viewer-in-microsoft-windows


One simple way to clear disk space and keep your computer running smoothly is to
uninstall applications you don’t need/use.
NOTE: Make sure you know what the application function is before you delete it, some
applications are key to keeping your computer functioning properly.

Find the list of applications by following these instructions.
How to Uninstall Windows Applications

Mac 3rd Party Tools
Etrecheck - Find serious problems on your Mac

https://etrecheck.com/
https://etrecheck.com/faq

MacKeeper - DO NOT USE THIS! (Uninstall if present)
Uninstall Instructions - be sure to clean up bits that may be leftover

PC 3rd Party Tools

 

Uninstall Unnecessary Applications

 
3rd Party Tools
See the list of 3rd party tools below, or visit these websites:

https://support.microsoft.com/en-us/help/17161/windows-10-find-all-your-apps-and-programs
https://support.microsoft.com/en-us/help/4028054/windows-10-repair-or-remove-programs
https://www.macworld.com/article/3151437/software/the-10-must-have-utilities-for-macos-sierra.html?page=2
https://etrecheck.com/
https://etrecheck.com/faq
https://www.macworld.com/article/2861435/software-utilities/how-to-uninstall-mackeeper-from-your-mac.html
https://www.pcauthority.com.au/feature/six-of-the-best-third-party-apps-to-transform-windows-10-430125


Caffeine
Quicksilver
Spectacle
Synergy
iStat Menus
Dropbox
Spotify
Google Chrome
Sublime Text

Mac OS

Ninite
Synergy
7-Zip
VLC Media Player
Spotify
FileZilla
WinDirStat
CPU-Z
GPU-Z
Dropbox
Google Chrome
Notepad++
Sublime Text

Windows

http://lightheadsw.com/caffeine/
https://qsapp.com/
https://www.spectacleapp.com/
https://symless.com/synergy
https://bjango.com/mac/istatmenus/
https://www.dropbox.com/?landing=dbv2
https://www.spotify.com/us/
https://www.google.com/chrome/
https://www.sublimetext.com/3
https://ninite.com/
https://symless.com/synergy
https://www.7-zip.org/
https://www.videolan.org/vlc/
https://www.spotify.com/us/
https://filezilla-project.org/
https://windirstat.net/
https://www.cpuid.com/softwares/cpu-z.html
https://www.techpowerup.com/gpuz/
https://www.dropbox.com/?landing=dbv2
https://www.google.com/chrome/
https://notepad-plus-plus.org/
https://www.sublimetext.com/3
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How to change your macOS Login Password

Change your macOS Login
Password

macOS

https://support.apple.com/guide/mac-help/mchlp1550/10.13/mac/10.13
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If you use a Microsoft account on your Windows 10 computer, you need to follow the instructions in
Method 2 of this guide (or sign into the Microsoft online website) to change your password.

 

1. Open the Control Panel. Set the View by option to Large icons. Click User Accounts.

 
2. Click the Manage another account link.

 
3. Click the user account that you want to change the password for.

 
4. On the next screen, click the Change the password option.

Change your Windows 10
Login Password
 

Windows 10

Method 1:
Change the Windows 10 Password from Control Panel



 
5. Type in your current password and then enter the new one you wish to use. Click

Change password.
 

 

1. Press the Windows + I keys together to open the Settings app. Click Accounts.

 
2. Click Sign-in options on the left side, and click the Change button under Password

section on the right side.

 
3. Enter your current password and click Next.

 
4. Enter and reenter a new password, and set a password hint. Click Next.

 

 

Method 2:
Change the Windows 10 Password from PC Settings
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Windows File History is a backup solution included with Windows 10 that behaves similarly to
Apple’s Time Machine. These instructions assume you are running Windows 10.

Note that File History will backup all folders and their contents within your user account’s home
directory (C:\Users\<your username>). That includes your Desktop, Documents, and Downloads
folders among others.

1. Press the Windows key/click the Start button.
2. Type “backup” without quotes.

3. The search results should include “Backup settings”. Click “Backup settings”.

Backing Up with Windows
File History

Initial setup



4. Click “Add a drive” to bring up a list of eligible backup drives.
5. Select your USB backup hard drive.

Note that in this example a 32 GB USB flash drive is being used as the backup drive.

This is an example only - use a USB hard drive for your backups.

6. “Add a drive” should now be replaced with an on/off switch for “Automatically back up my
files” with the switch in the On position. Your files are now backing up automatically.

 

1. Return to the File History settings page (steps 1-3 of Initial setup above).

2. Click “More options”.

3. Back up my files: The default of every hour is good.
4. Keep my backups: I recommend setting this to 3 months, which will simply remove

backups from over 3 months ago. Any reasonable timeframe or the “Until space is

needed” option are fine choices.

5. Add a folder: You can optionally add folders you want backed up that are outside of your
user account’s home directory (C:\Users\<your username>).

 

1. Return to the File History settings page (steps 1-3 of Initial setup above).
2. Click “More options”.
3. Scroll to the bottom. Click “Restore files from a current backup” under “Related settings”.
4. Navigate to the time/date of the backup you wish to restore.
5. Restore SPECIFIC files/folders in-place

Select the file(s) and/or folder(s) you wish to restore.
Click the big green restore button labeled “Restore to original location” to replace
the current version of the file(s) and/or folder(s) with the one(s) from your chosen
backup.

Additional configuration

Restore files



6. Restore ALL files/folders in-place
NOTE: You probably do not want to do this. Changes to every file and folder since
your selected backup will be lost and replaced with the version from your backup.
Click the big green restore button labeled “Restore to original location” to replace
the current version of all your files and folders with the ones from your chosen
backup.
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1. Right-click on the file you want to open.
2. Mouse over the Open With... menu option, and select Choose Program...
3. Select the desired program from the list, or browse for a program if it is not listed.
4. Check the "Always use the selected program..." checkbox.
5. Click OK.

1. Right-click on a file and select "Get Info". (The shortcut is command-I)
2. In the file info window, under "Open with", select the application you want as the default

from the drop-down menu.
1. If the application you want to use is not listed,
click the "Other..." button.

Change the Default
Application Associated with
a File Type

Windows

macOS

Method 1 (Recommended):



2. If the application you want to use is greyed out in the
"Choose and application to open the document ________ "
window, change the "Enable" setting from "Recommended
Applications" to "All Applications".
3. Check the "Always Open With" check box and click "Add".

3. Once you have selected your application, you have the choice to make this change affect
all files of this type, or just this one. To have this change affect just this one, simply close
the window. For the change to affect all files of this type, press the "Change All..." button.

4. When you are prompted to "Change all similar documents to open in the application
_________ ", click the "Continue" button.

5. The selected file type should now open using the application selected in the steps above
when the file is double-clicked.

1. Right-click on a file, point to "Open With" and select "Other..."
2. Browse to your Applications directory and select the application you want to open the file

type by default, check the "Always Open With" check box and click "Open". (NOTE: If the
application you want to use to open the file is greyed out, change the "Enable" setting
from "Recommended Applications" to "All Applications".)

3. The selected file type should now open using the application selected in the steps above
when the file is double-clicked.

Method 2:
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Determine the make and model of the device for which you want to update the drivers. If it's an
external device (printer, scanner, webcam, etc.) you can usually read the make and model number
right off the device. If the make and model info is not easy to determine, you'll need to do some
research to figure it out. You should be able to find the information using one of the following
methods:

Windows 10:

1. Select Start, in Search, type Device Manager, and select it from the list of results.
2. Select Search automatically for updated driver software.
3. If Windows doesn't find a new driver, you can try looking for one on the device

manufacturer's website and follow their instructions.

From the manufacturer's website (recommended):

1. Go to the device manufacturer's website.
2. Locate the Software and Driver download page on their support site.
3. Search for the specific model number of the device.
4. Locate and download the driver specific to your device and operating system. (Determine

your operating system by right-clicking My Computer and selecting "properties".

 

How do I install device
drivers?
 

Identify the device (Windows)

 

Download the Drivers



Some drivers are provided as a self-extracting, self-installing executable package. Some will be a
self-extracting archive that contains an installer you need to run. Others will be a file or set of files
that need to be installed manually.

To install drivers from an installer:

1. Double-click the installer file.
2. Click through the installation process.
3. After the installer finishes, restart your computer to complete the installation process.

To update drivers in Windows 10 click here.

Install the Drivers

https://support.microsoft.com/en-us/help/4028443/windows-10-update-drivers


Operating Systems

 

A good place to start is Apple's Mac 101 web site:
http://www.apple.com/support/mac101/

Help for New Mac Users

http://www.apple.com/support/mac101/


Operating Systems

 

As of Windows 10, Windows will automatically start in Safe Mode if it detects that you are unable to
boot up normally. It may take 2-3 tries before Windows starts in Safe Mode.

If your computer boots normally and you want to enter Safe Mode, such as to install software which
isn't working in normal mode, follow these steps: https://support.microsoft.com/en-
us/windows/start-your-pc-in-safe-mode-in-windows-10-92c27cff-db89-8644-1ce4-b3e5e56fe234

Start your Windows
Computer in Safe Mode

https://support.microsoft.com/en-us/windows/start-your-pc-in-safe-mode-in-windows-10-92c27cff-db89-8644-1ce4-b3e5e56fe234
https://support.microsoft.com/en-us/windows/start-your-pc-in-safe-mode-in-windows-10-92c27cff-db89-8644-1ce4-b3e5e56fe234


Operating Systems

One of the features of macOS is the ability to issue commands during the startup of the  macOS to
perform specific operations or evoke different startup states. In order to issue the commands
associated with the different key combinations, the key combinations must be pressed at the
moment the startup chime sound is heard and the screen changes color from black to grey on
system startup and held until the desired operation occurs.

Please note that these key combinations only work on Macs with Intel processors. For newer Macs
with Apple Silicon chips, follow this guide to access different startup options:
https://support.apple.com/guide/mac-help/macos-recovery-a-mac-apple-silicon-mchl82829c17/mac

Option - Display all bootable volumes (Startup Manager)
Shift - Perform Safe Boot (start up in Safe Mode)
C - Start from a bootable disc
T - Start in FireWire target disk mode
X - Force Mac OS X startup (if non-Mac OS X startup volumes are present)
Command-V - Start in Verbose Mode
Command-S - Start in Single User Mode
Mouse button - Force eject CD/DVD

More information about macOS key commands are available on the Apple website:
http://support.apple.com/kb/HT1343

More startup key-command information:
https://support.apple.com/en-us/HT201255

macOS Startup Key
Commands

https://support.apple.com/guide/mac-help/macos-recovery-a-mac-apple-silicon-mchl82829c17/mac
http://support.apple.com/kb/HT1343
https://support.apple.com/en-us/HT201255


Operating Systems

https://www.virtualbox.org/wiki/Downloads

https://www.extremetech.com/computing/1 ... al-machine

IMPORTANT: Make sure you install the Guest Additions and create shared folders.
(When you create a shared folder, make sure you check the "make permanent" check
box)

Once you've installed VirtualBox and created a VM, you can use Ninite to install
essential Windows applications:

http://ninite.com/

Use VirtualBox to Create a
Windows Virtual Machine
 

Download VirtualBox:

Instructions for creating a Windows 10 virtual machine using
VirtualBox:

https://www.virtualbox.org/wiki/Downloads
https://www.extremetech.com/computing/198427-how-to-install-windows-10-in-a-virtual-machine
https://www.virtualbox.org/manual/ch04.html
http://helpdeskgeek.com/virtualization/virtualbox-share-folder-host-guest/
http://ninite.com/


Operating Systems

Creating a disk image is a great way to keep your computer and files backed up. This is
one of two ways IT recommends backing up your devices. The other way is to back up
with Windows File History or macOS Time Machine.

Follow the instructions below to create a disk image:

1. Download Macrium Reflect
2. During installation:

1. Do not include the PE environment
2. Reflect Defaults:

1. Backup - set priority to 3/4
2. Advanced - Disable backup notification

3. Once installation complete, configure backup settings:
1. Open Macrium Reflect
2. Select "Create an image of the partition(s) required to backup and restore Windows"

on the left side panel of Macrium

Create a Disk Image Backup
with Macrium Reflect

https://www.macrium.com/reflectfree


3. Make sure the whole disk is selected (far left box is checked, as well as all sections
of that disk are checked)

4. Set your destination of the images you create



5. Click Next
6. Select a Template for your Backup Plan: Differential Backup Set
7. Select Edit Schedule with Full highlighted

1. Configure settings:
1. Monthly
2. Every first Sunday at 3:00am

2. Conditions: (check all mentioned)
1. Run task as soon as possible after a scheduled start is missed
2. Start the task only if the computer is on AC power
3. Wake the computer to run this task

3. Select OK
8. Select Edit Schedule with Differential highlighted

1. Configure settings:
1. Daily
2. Weekdays at 12:30pm

2. Conditions: (check all mentioned)
1. Run task as soon as possible after a scheduled start is missed
2. Start the task only if the computer is on AC power



3. Wake the computer to run this task
3. Select OK

9. Define Retention Rules
1. Full: change amount to 2, change from "Weeks" to "Backups"
2. Differential: change to 30 Days

10. Hit Finish
11. Hit OK



Information on installing and using Word, Excel, and Powerpoint.

Microsoft Office



Microsoft Office

Discounts for MS Office for personal use are available for Faculty, Staff, and Students at SJSU and 

CSUMB OnTheHub.

Also, see the MLML Software Availability Page.

If your work computer is state-owned, and you would like to request an install of Microsoft Office,
please submit an IT Helpdesk Ticket.

Request Microsoft Office for
State-Owned Computers
 

Free versions of Microsoft Office are only available for state-owned
computers.

https://sjsu.onthehub.com/
https://csumb.onthehub.com/
https://mlml.sjsu.edu/itech/software/
http://helpdesk.mlml.calstate.edu


Microsoft Office

Note: If you are a student currently enrolled at MLML through SJSU or CSUMB, you can download
Microsoft Office 365 for free using your school email account.

The Microsoft Office 365 Education package provides all of the software that students normally
need, including Word, Excel, PowerPoint and more.

To download the package, please follow these directions carefully:

1. Go to this link.
2. Enter your school email address.

If you are an SJSU student, make sure you enter your @sjsu.edu address. If you are
a CSUMB student, enter your @csumb.edu address.

3. Click the button that says "I'm a student".
4. Enter the info needed to create a new account (You should have a new email in your

corresponding inbox containing your verification code. If you don't see it immediately, be
sure to check your spam folder).

5. Once all of the information is entered, click start.
6. Skip the invitations (or share with friends who might also need Office 365!)
7. Arrow through the promotion/tutorial box that pops up.
8. This should bring you to a page with Office 365 and a greeting at the top. From here you

can choose to either download and install the entire 365 package for your computer
(recommended if you have nothing on your computer), or just use the individual features
from online.

9. If you wish to install Office 365 on your computer, click the Install Office 2016 button in
the upper right hand corner of the page.

10. Double click the download to open the installer file.
11. Complete installation.
12. Sign in with the new account that you created to activate Office.

And voila! You should now have full access to Microsoft Office online and on your desktop.

 

Microsoft Office Installation
for Students

Troubleshooting: What to do if the school sign in page does
not work for you

https://products.office.com/en-us/student?ms.officeurl=getoffice365


*Before you begin, make sure you are completely exited out of the Microsoft page and SJSU/CSUMB
sign in page*

1) Log on to gmail in your web browser and sign in to your SJSU/CSUMB email

2) Click your name/account in the upper right corner and click "manage your google account"

3) Click "security" on the left hand side

4) Scroll down to "signing in to google" and click "password"

5) Follow the steps to reset your password

6) Exit out of the Gmail tab

7) Go back to the Microsoft sign up page and put in the new password you just made

8) It might take you through a series of verification steps for your phone number and a back-up
email address - follow these steps

9) This should lead you to the school's Microsoft page, click "install office" in the upper right hand
corner to download the suite
 

If you get stuck at step #4 in this process because your school email
address or password is deemed invalid, follow the guidelines below:

https://products.office.com/en-us/student?ms.officeurl=getoffice365


Microsoft Office

 

https://www.office.com/
http://www.microsoft.com/mac/
https://support.office.com/en-us/office ... l=training
http://www.microsoft.com/downloads/en/d ... 12f59bd428
If you have access to LinkedIn Learning (All SJSU affiliates):
https://www.linkedin.com/learning/learning-office-365-microsoft-365/increase-your-
productivity-with-office-365

Microsoft Office 365 Info and
Tutorials

Microsoft Office 365:

https://www.office.com/
http://www.microsoft.com/mac/
https://support.office.com/en-us/office-training-center?ms.officeurl=training
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3bc6bade-2b14-4530-9a93-c712f59bd428
https://www.linkedin.com/learning/learning-office-365-microsoft-365/increase-your-productivity-with-office-365
https://www.linkedin.com/learning/learning-office-365-microsoft-365/increase-your-productivity-with-office-365


Microsoft Office

 

Word 2011 and 2016:

1. Open Word, click on File > Preferences... > Save.
2. Change the "Save Word files as" setting to "Word 97-2003 Document" (.doc).
3. Click OK to save the settings.

2019/365:

1. On the File tab, click Save As, and then click Browse.
2. In the Save As dialog box, in the Save as type list, click PowerPoint 97-2003

Document (*.doc).
3. Click Save.

Excel 2011 and 2016:

1. Open Excel, click on File > Preferences... > Compatibility.
2. Change the "Save files in this format" setting to "Excel 97-2003 Workbook (.xls)".
3. Click OK to save the settings.

2019/365:

1. Click File > Export > Change File Type.
2. Under Workbook File Types, double-click Excel 97-2003 Workbook (*.xls).
3. In the Save As popup window, choose a folder location for the workbook.
4. In the File name box, type a new file name (or use the one that’s already there).
5. Click Save.
6. If the Compatibility Checker appears, review any compatibility issues that were found.

Configure Office to Save in
Compatibility Mode



PowerPoint 2011 and 2016:

1. Open PowerPoint, click on File > Preferences... > Save.
2. Change the "Save PowerPoint files as" setting to "PowerPoint 97-2003 Presentation"

(.ppt).
3. Click OK to save the settings.

2019/365:

1. On the File tab, click Save As, and then click Browse.
2. In the Save As dialog box, in the Save as type list, click PowerPoint 97-2003

Presentation (*.ppt).
3. Click Save.



Microsoft Office

OneDrive is a cloud storage system by Microsoft as part of its suite of Office Online services. You
can sync multiple Windows products together for easy access and automatic backup. Check out
OneDrive's Help Center to learn about OneDrive's other storage capabilities.

How to sync with Windows:
Click on the following link to sync OneDrive on Windows.

How to sync with Mac:
Click on the following link to sync OneDrive on Mac.

How to upload photos automatically on your phone:
Android:
Click on the following link and scroll down to the “Automatically upload photos and videos you take
to OneDrive” section

iOS:
Click on the following link and scroll down to the “Automatically save photos and videos you take to
OneDrive” section

How to create an album:
OneDrive is capable of creating albums for your photos and videos automatically based on the date
they were taken. Click here and scroll down to the “Automatic album creation” section. To create
your own album scroll down to the “Create your own album” section

How to add tags to your photos:
Click here and scroll down to the “Edit or remove a tag” section.

OneDrive Image
Management FAQ

https://onedrive.live.com/about/en-us/
https://support.office.com/en-us/onedrive
https://support.office.com/en-us/article/sync-files-with-the-onedrive-sync-client-in-windows-615391c4-2bd3-4aae-a42a-858262e42a49
https://support.office.com/en-us/article/sync-files-with-the-onedrive-sync-client-on-mac-os-x-d11b9f29-00bb-4172-be39-997da46f913f
https://support.office.com/en-us/article/use-onedrive-on-android-eee1d31c-792d-41d4-8132-f9621b39eb36
https://support.office.com/en-us/article/use-onedrive-on-ios-08d5c5b2-ccc6-40eb-a244-fe3597a3c247
https://support.office.com/en-us/article/organize-and-find-photos-in-onedrive-6a9b0298-f504-4992-af0e-45e2f270afc9
https://support.office.com/en-us/article/organize-and-find-photos-in-onedrive-6a9b0298-f504-4992-af0e-45e2f270afc9


Microsoft Office

 

Utilizing 2 monitors, and in this case a laptop with a VGA output, you can view all of your slides
along with notes on your laptop screen and only the full screen presentation is seen on the VGA
output (projector). 

NOTE: Before configuring PowerPoint, be sure that your computer is connected to an external
display and that your video settings are configured as "extended desktop" or "dual view" rather
than "mirrored" or "clone".

Here is a link on what Presenter View is all about and how to use it: https://support.office.com/en-
us/articl ... 4736928ee3

Configure the Display Properties:

1. Right click on your desktop and click on Properties
2. Click on the settings tab.
3. Click on the secondary monitor, in this case most of the time it will appear greyed out and

have a 2 on it.
4. Next check Extend my Windows desktop onto this monitor and click OK.

Configure PowerPoint to use Presenter View:

1. Connect your laptop to a projector or other external video device.
2. In PowerPoint, on the Slide Show menu, click Set Up Show.
3. Under Multiple monitors, select the Show Presenter View check box.
4. In the Display slide show on list, click the monitor you want the slide show presentation to

appear on.
5. To start the presentation, click the start presentation icon, or press Shift+F5.

Using PowerPoint's Presenter
View

 

Windows:

https://support.office.com/en-us/article/what-is-presenter-view-98f31265-9630-41a7-a3f1-9b4736928ee3
https://support.office.com/en-us/article/what-is-presenter-view-98f31265-9630-41a7-a3f1-9b4736928ee3


1. Connect your laptop to a projector or other external video device.
2. Open System Preferences.
3. Select the Displays System Preference and click "detect displays"
4. Open your PowerPoint presentation and click on: Slideshow > View Presenter Tools.

 

macOS:



Microsoft Office

If you will be presenting on a different computer than the one on which it was created or if you wish
to distribute your PowerPoint Presentation, save your PowerPoint in a portable format. This will
insure that images and video in your PowerPoint presentations are saved along with the PowerPoint
file itself and will load properly when played on a different computer:

Office 2003 (Windows):

1. Open the PowerPoint file.
2. Click File > Package for CD...
3. Enter a name for the portable presentation and click the "Copy to Folder..." button.
4. Name the folder, select a location to save and click OK.

More details about saving portable PowerPoint presentations on PowerPoint 2003 are available 
here.

Office 2007 (Windows):

1. Open the PowerPoint file.
2. Click the Office button at the top left of the PowerPoint 2007 screen.
3. Select Publish > Package for CD
4. Enter a name for the portable presentation and click the "Copy to Folder..." button.
5. Name the folder, select a location to save and click OK.

More details about saving portable PowerPoint presentations on PowerPoint 2007 are available 
here.

Office 2010 (Windows):

Saving a Portable
PowerPoint Presentation
 

Portable PowerPoint Presentations:

https://www.uwec.edu/kb/article/microsoft-powerpoint-2003-making-presentations-portable/
http://presentationsoft.about.com/od/powerpoint2007/ss/071202package07_7.htm


1. Open the PowerPoint file.
2. Click the File tab.
3. Click Save & Send, then click Package Presentation for CD.
4. Click the Package for CD button.
5. Enter a name for the portable presentation and click the "Copy to Folder..." button.
6. Name the folder, select a location to save and click Select.
7. When prompted to include linked files, click yes.

More details about saving portable PowerPoint presentations on PowerPoint 2010 are available 
here.

Office 2004 (Mac OS X):

1. Open the PowerPoint file.
2. Click File > Save As... and select "PowerPoint Package" from the "Format" drop-down

menu.
3. The PowerPoint presentation will be saved to a folder with all image and video files. Copy

the entire folder to your flash drive or burn it to a CD in order to view the PowerPoint
presentation on a different computer.

 

Office 2008 (Mac OS X):

1. Open the PowerPoint file.
2. Click File > Save As... and select "PowerPoint Package" from the "Format" drop-down

menu.
NOTE: The PowerPoint presentation will be saved as a .pptx. If the version of Office you
are using is not able to handle .pptx files, you can download and install a file format
converter that will enable older versions of PowerPoint to open files created in the Office

2008. More information can be found here.
3. The PowerPoint presentation will be saved to a folder with all image and video files. Copy

the entire folder to your flash drive or burn it to a CD in order to view the PowerPoint
presentation on a different computer.

 

Office 2011 & Newer (Windows & Mac OS X):

Since PowerPoint 2011, PowerPoint embeds images and video into the presentation by
default when saving, making all recent PowerPoint presentations portable. There is no
longer a need to specify saving the PowerPoint presentation in a portable format.
1. On the File tab, select Save.
2. Do of the following:

http://office.microsoft.com/en-us/powerpoint-help/package-a-presentation-for-cd-HA010336719.aspx
https://kb.mlml.sjsu.edu/viewtopic.php?f=34&t=269&p=338


To save to your local drive, such as your laptop, a flash drive, CD or DVD drive,
select Computer.
To save to a SharePoint Library, select SharePoint.
To save your presentation to a web location, see Save and share a presentation
to OneDrive.

3. Under Save As > Recent Folders, select Browse, pick a path and file folder, and then
name the file.

4. Select Save.

https://support.office.com/en-us/article/save-and-share-a-presentation-to-onedrive-cdbec569-a18f-4bdc-92e8-d07a8ab5eb95
https://support.office.com/en-us/article/save-and-share-a-presentation-to-onedrive-cdbec569-a18f-4bdc-92e8-d07a8ab5eb95


Microsoft Office

1. Select the Start button, then select Settings > Apps.
2. Choose the program you want to remove, and then select Uninstall.
3. To remove an app you got from Microsoft Store, find it on the Start menu, press and hold

(or right-click) on the app, then select Uninstall.

For more information, go here.

1. Open Finder > Applications.
2. Command +click to select all of the Office for Mac applications.
3. Ctrl+click an application you selected and click Move to Trash.

For more information, go here.

How do I Uninstall Office?
Windows:

macOS:

https://support.office.com/en-us/article/uninstall-office-from-a-pc-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8
https://support.office.com/en-us/article/uninstall-office-for-mac-eefa1199-5b58-43af-8a3d-b73dc1a8cae3


Microsoft Office

What does this procedure actually do and why am I doing it?

You are essentially testing your Office .plist files to determine if they are the source of the problem
with an Office application. "Testing" a preference file simply refers to removing the preference file
from the default location (~/Library/Preferences/) and verifying that the Office application starts
normally (the Office application will automatically re-create a preference file when it starts if the
preference file does not already exist in the default location. To test a preference file, simply move
the file from the default location to a different folder, for example a folder you create on your
desktop.

Mac OS X only:

1. Quit all Office applications.
2. Navigate to your ~/Library/Preferences/ folder and drag the file(s) listed in the section

below to your desktop. To access the ~/Library/ folder, from Finder, hold the option key
and click the Go menu, then select the Library from the Go menu.
(NOTE: "~" indicates your user home directory. (ie. /Macintosh HD/Users/yourusername/)

3. Move the following files from your Preferences folder to a folder on your Desktop:
~/Library/Preferences/com.microsoft.Word.plist
~/Library/Preferences/com.microsoft.Excel.plist
~/Library/Preferences/com.microsoft.PowerPoint.plist

4. Relaunch the problematic application (Word, Excel or PowerPoint).
The .plist file(s) will be recreated when you do so.

5. If the application starts successfully and is running normally, trash the old file(s). In the
case of the Word Preferences/Settings file, you will have to reset some preferences (and,
for versions earlier than Word 2008, the AutoCorrect settings).

6. If this doesn't fix the issue, quit all Office applications again, move the Office .plist files to
a folder on your Desktop. The Office .plist files are as follows:

~/Library/Preferences/com.microsoft.office.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist

7. Relaunch the problematic application (Word, Excel or PowerPoint).
8. If this procedure doesn't work for you or causes other issues with your office applications,

I recommend that you move the new files to the Trash and drag the original files back to
where they belong. (If you are using Office 2008 or Newer, look for leftover preferences
from earlier versions (see below) and remove them from your preferences folder).

Word, Excel, or PowerPoint
Crashes or Freezes (macOS)



In Office 365/2019, 2016, 2011, or 2008:
~/Library/Preferences/com.microsoft.Word.plist
~/Library/Preferences/com.microsoft.Excel.plist
~/Library/Preferences/com.microsoft.PowerPoint.plist

If testing these files in Office did not fix the problem, then check to see if you have leftover
preferences from Office 2004 or earlier versions. The .plist files for 2004 are listed below.

In Word 2004:
~/Library/Preferences/Microsoft/com.microsoft.Word.prefs.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist
~/Library/Preferences/Microsoft/Office Font Cache

In Excel 2004:
~/Library/Preferences/Microsoft/com.microsoft.Excel.prefs.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist
~/Library/Preferences/Microsoft/Office Font Cache

In PowerPoint 2004:
~/Library/Preferences/Microsoft/com.microsoft.PowerPoint.prefs.plist
~/Library/Preferences/Microsoft/com.microsoft.Office.prefs.plist
~/Library/Preferences/Microsoft/Office Font Cache

In Word X:
~/Library/Preferences/Microsoft/Word Settings
~/Library/Preferences/Microsoft/Microsoft Component Preferences
~/Library/Preferences/Microsoft/Microsoft Office Settings
~/Library/Preferences/Microsoft/Carbon Registration Database
~/Library/Preferences/Microsoft/Office Font Cache



Microsoft Office

 

When presenting in the seminar room, for recording purposes the best presentation size is
widescreen (16:9).

1. Open PowerPoint.
2. Select the Design Tab.
3. Select Slide Size and click on widescreen (16:9).

Converting your PowerPoint
Presentation to Widescreen
(16:9)



Microsoft Office

 

Instructions for using the "Transpose" command to manipulate data are located here:

https://support.office.com/en-us/articl ... f862209744

Convert Columns to Rows, or
Rows to Columns using Excel

https://support.office.com/en-us/article/transpose-rotate-data-from-rows-to-columns-or-vice-versa-3419f2e3-beab-4318-aae5-d0f862209744


Information about Adobe Acrobat, the Adobe Creative Cloud package, and PDFs

Adobe



Adobe

The Adobe Creative Cloud (CC) Package provides many creative editing tools for Windows and OS X
including Acrobat, Illustrator, Photoshop, Dreamweaver, Premiere, and more. Adobe CC is
available to SJSU and CSUMB faculty, staff, and students at no-cost for the entire duration of their
affiliation with either institution.

Installation of Adobe CC requires 50 GB of free space on the hard drive (HD). Please make sure that
your computer system meets the requirements and has sufficient HD space before beginning the
installation. System requirements for Mac OSX and Windows may be found here.

NOTE: Follow this procedure to access Adobe Creative Cloud on both personal and
state/foundation owned computers. You will be able to install Adobe CC on as many computers as
you like and actively use Adobe Apps on two computers at a time.

1. Fill out the Adobe Access Form using your SJSUOne ID and password
1. Student Adobe Access Form
2. Faculty/Staff Adobe Access Form

2. If you are eligible, click Register

screenshot.png
 

3.  You will receive an email from Adobe to your SJSU gmail account within a few hours of
submitting the form.

4. Open the email and click Get Started

screenshot3.png

Adobe Creative Cloud
Information & Installation

System Requirements

Adobe CC Access & Installation Procedure
SJSU Faculty, Staff, and Students

https://helpx.adobe.com/in/creative-cloud/system-requirements.html#requirements
https://adobelicensing.sjsu.edu/Login?ReturnUrl=%2fEligibility%2fDefault.aspx
https://adobelicensing.sjsu.edu/Login?ReturnUrl=%2fEligibility%2fDefault.aspx
https://kb.mlml.sjsu.edu/uploads/images/gallery/2021-08/screenshot.png
https://kb.mlml.sjsu.edu/uploads/images/gallery/2021-08/screenshot3.png


5. Sign into SJSU's single sign on portal by entering your SJSU ID and password and verify
using DUO

6. You will be redirected to Adobe's homepage where you will see the option to install Adobe
CC

7. For detailed instructions on how to install Adobe CC and Adobe Apps reference this
Installation and Resource Guide

NOTE: Follow this procedure to access Adobe Creative Cloud on both personal and
state/foundation owned computers. You will be able to install Adobe CC on as many computers as
you like and actively use Adobe Apps on two computers at a time.

1. Navigate to adobe.com
2. Click Sign In in the upper right corner and enter your CSUMB email address
3. Click Continue

screenshot2.png
4. You will be redirected to CSUMB's single sign on, enter your username and password
5. You will again be redirected back to Adobe's website, and you now have access to Adobe

CC
1. Here you can install the Adobe CC app onto your computer and use it to install the

programs you want from the Adobe CC App

1. Sign out of the Creative Cloud Desktop app and close it
2. Open File Explorer (windows) or Finder (mac) and navigate to the ServiceConfig.xml file:

Windows: C:\Program Files (x86)\Common
Files\Adobe\OOBE\Configs\ServiceConfig.xml
MacOS: Macintosh HD/Library/Application
Support/Adobe/OOBE/Configs/ServiceConfig.xml

3. Copy ServiceConfig.xml to your desktop
4. Open the copy of the ServiceConfig.xml file with Notepad (windows) or TextEdit (mac)
5. Change the following line from

<panel><name>AppsPanel</name><visible>false</visible></panel>
to
<panel><name>AppsPanel</name><visible>true</visible></panel>

6. Save the copy of the ServiceConfig.xml file to your desktop
7. Rename the original ServiceConfig.xml file in the Configs folder to ServiceConfig-old.xml

CSUMB Faculty, Staff, and Students

Troubleshooting
Adobe CC displays "You don't have access to manage apps" error
when installing apps

https://www.sjsu.edu/ecampus/docs/Adobe-SJSU-intall-guide.pdf
https://www.adobe.com/
https://kb.mlml.sjsu.edu/uploads/images/gallery/2021-08/screenshot2.png


8. Copy and paste the altered ServiceConfig.xml file from your desktop into the Configs
folder

9. Restart your computer
10. You should now no longer receive the error message when installing new apps

Additionally, here are some video walkthroughs of the procedure described above:

Windows: https://www.youtube.com/watch?v=FyphY4QJk44
MacOS: https://www.youtube.com/watch?v=jr2jlngK4wU

https://www.youtube.com/watch?v=FyphY4QJk44
https://www.youtube.com/watch?v=jr2jlngK4wU


Adobe

Windows

1. Open the image you want to convert to a PDF
2. Right click on the image and select "Convert to Adobe PDF"
3. Save the new PDF to the location of your choice

Mac

1. Open the image you want to convert to a PDF
2. Click File > Export as PDF
3. Save the PDF to the location of your choice

Windows and Mac

1. Open the word document you want to convert to a PDF
2. Click File > Save As
3. Select the location where you want to save the PDF
4. Select "PDF" as the file type from the drop down
5. Save the document

 

Save a Document or Image
as an Adobe PDF
Images

Word/Excel/PowerPoint Documents



Adobe

This procedure has been verified on Adobe Acrobat 8 Professional:
(The procedure outlined should work with Acrobat v7, v8 and v9)

1. Save the document as a PDF.
(Instructions for creating a PDF are located here: Save a Document or Image as PDF)

2. Open the document in Adobe Acrobat (Adobe Reader cannot edit PDFs).
3. Navigate to the Forms menu.
4. Select Run Form Field Recognition and allow the conversion to complete.
5. Save the document as a PDF. (Choose a different file name to avoid overwriting your

original document)
6. Be sure to verify that all desired fields are fillable prior to distribution.

HINT: Use the "Highlight Fields" button or menu option to show which fields were
automatically created.

7. If more fields need to be created, use the "Forms" toolbar. Open the Forms toolbar from:
View > Toolbars or Tools > Forms > Show Forms Toolbar.

Once the fillable form has been created, users can fill the form using any standard PDF viewing
application.

For Adobe Acrobat Pro DC:

1. Save the document as a PDF.
(Instructions for creating a PDF are located here: Save a Document or Image as PDF)

2. Open the document in Adobe Acrobat (Adobe Reader cannot edit PDFs).
3. Within Acrobat, click on the Tools tab and select Prepare Form.
4. Select a file or scan a document. Acrobat analyzes your document and adds form fields

automatically.
5. Add new form fields from the top toolbar, and adjust the layout using tools in the right

pane.
6. Save your fillable PDF form and share it with others, or click Distribute to collect responses

automatically.

Convert a document to a
fillable PDF form using
Adobe Acrobat

https://kb.mlml.sjsu.edu/books/software/page/save-a-document-or-image-as-a-pdf
https://kb.mlml.sjsu.edu/books/software/page/save-a-document-or-image-as-a-pdf


More information about creating fillable PDFs is available on Adobe's website:
https://acrobat.adobe.com/us/en/acrobat ... eator.html

Also see our DocuSign FAQ to learn how to convert PDFs into fillable PDFs online.

https://acrobat.adobe.com/us/en/acrobat/how-to/create-fillable-pdf-forms-creator.html
https://kb.mlml.sjsu.edu/books/administrative-services/page/docusign-faqs


Adobe

When having to fill out a PDF form, some forms can be filled electronically. If your PDF form is
fillable, here’s how you fill it out and print the completed form. For more information, see Adobe’s
Support Page on completing electronic forms.

 

1. Make sure you have Adobe Reader installed on your computer.

Faculty or staff members with a valid SJSUOne ID can use DocuSign to have recipients fill
out and sign documents online. Refer to our DocuSign FAQs for more information.
Download the fillable form onto your computer and open the file in Adobe Reader.
To make form fields easier to identify, click the Highlight Existing Fields   button on
the document message bar, if necessary.

Select the Hand Tool. 

Select the fillable highlighted field on your form. An I-beam will appear for you to type in
the text or arrow to select or check boxes.
Fill in the necessary information for each field.
Example: 

How to Fill PDFs
Electronically Using Adobe
Reader

https://helpx.adobe.com/reader/using/fill-forms.html
https://helpx.adobe.com/reader/using/fill-forms.html
https://get.adobe.com/reader/
https://sjsu.okta.com/login/login.htm?fromURI=%2Fhome%2Fdocusign%2F0oab5wk2fzgtwvTpM0x7%2F292
https://kb.mlml.sjsu.edu/books/internal-resources/page/docusign-faqs


Once you have finished filling the form, Save your form by printing as a PDF in order to
email or print.

Windows:
Select File > Print.
Choose Adobe PDF as the printer in the Print dialog box.
Click Print. Type a name for your file, and click Save.

MacOS:
Select File > Save As.
Select a location to save, type a name for your file, and click Save.
To flatten your form so that it cannot be edited, open the file in the MacOS
Preview application.
Select File > Export As PDF...
Select a location to save, type a name for your file, and click Save.



Adobe

Create protected PDFs
Prevent others from copying or editing sensitive information

Edit PDF text and images 
Fix a typo or swap an image in a PDF from your computer, iPad, or Android tablet

Convert creative filed and images to PDF
Turn Adobe Photoshop, Illustrator, or InDesign files into PDFs

Simplify and speed up PDF reviews
Collect group feedback in one PDF file online with no reviewer login required. Let
reviewers see ea h other's feedback and clear up any confusion with @-mentions

Export PDFs to Office
Convert PDFs to Word, Excel, or Powerpoint and keep the formatting

Firstly, please visit our Adobe Creative Cloud Information and Installation page to get information
on how to access and download Adobe applications for free through your student account

Second, to find out how to use the Acrobat DC app to design and edit your documents, take a look
at the following tutorials from Adobe's website: 

Getting started with Acrobat DC
Use this webpage to learn the basics of Acrobat, including how to create a new PDF
file, edit and comment on your PDF file, and add a password to protect your file from

Adobe Acrobat
Adobe Acrobat is an application that
allows you to connect with your
documents, access essential PDF and e-
signature tools, and make collaboration on
PDF reviews easy from any device.
Here is a list of uses for the Adobe Acrobat DC app:

Getting started with Acrobat as an MLML student

https://kb.mlml.sjsu.edu/books/software/page/adobe-creative-cloud-information-installation
https://helpx.adobe.com/acrobat/tutorials.html
https://helpx.adobe.com/acrobat/how-to/get-started-acrobat-dc.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:orientation/en_us.json&ref=helpx.adobe.com


unwanted visitors
How to create PDFs from text and image files
How to customize your Acrobat toolbar 
How to combine files into one PDF 
How to create PDFs from Microsoft Office 
How to add annotations and sticky notes to your PDF
How to extract pages from a PDF 
How to split a PDF file
How to turn paper documents into searchable PDFs

 

https://helpx.adobe.com/acrobat/how-to/create-pdfs-from-text-image.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:orientation/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/customize-toolbar.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:orientation/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/combine-files-into-pdf.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:basictraining/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/create-pdf-files-word-excel-website.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:basictraining/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/add-pdf-comment.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:continuinged/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/extract-pages-from-pdf.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:continuinged/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/split-pdf-file.html?playlist=/services/playlist.helpx/products:SG_ACROBAT_PK~12/learn-path:get-started/set-header:ccx-designer/playlist:continuinged/en_us.json&ref=helpx.adobe.com
https://helpx.adobe.com/acrobat/how-to/scan-paper-documents-searchable-pdf.html


Learn how to install, update a license, and enable toolboxes/extensions.

ArcGIS



ArcGIS

1. Click this link to be taken to the ArcGIS portal.
2. Click Sign in.
3. Click SJSU Okta.
4. Sign in with your SJSU TowerID number and password.

1. At the top right of the page, click your profile picture and click My settings.
GIS_FULL_SELECT.png

2. On the My Settings page, click the Licenses tab.
3. Your user type, role, and assigned licenses are listed.
4. Next to ArcGIS Pro, click Download.
5. Select destination folder - either default or browse & choose a different folder.
6. This will initiate the extraction of the installation files.

1. Once the files are extracted check the box at the bottom of the screen to open installation
files.

2. Click Close.
3. The installation will commence.
4. Accept the master agreement > Next.
5. Choose your installation method preference:

1. Complete - all apps and features installed (best for basic/intermediate ArcGIS users)
2. Custom - you hand pick which apps and features you'd like to install (best for

advanced users)
6. Click Next.
7. Select designation folder - either default or browse & choose a different folder

1. This will occur twice in a row: once for installation files, the other for python files
8. Check or uncheck the "participate in Esri User Experience Improvement program" based

on your preference.

Gaining Access to ArcGIS Pro
To gain access to ArcGIS Pro, please follow the steps
outlined below.
Note: you will need to run ArcGIS Pro on a windows computer.

Activating your ArcGIS Account

Downloading ArcGIS Pro 

Installation of ArcGIS Pro

https://sjsugis.maps.arcgis.com/home/index.html
https://kb.mlml.sjsu.edu/uploads/images/gallery/2022-08/gis-full-select.png


9. Click Install.
10. Allow the installation process to complete and click Finish.
11. The ArcGIS Administrator Wizard will likely automatically open.
12. Select Sign in with your organization's ArcGIS URL.
13. Finish.
14. Now ArcGIS should be installed.

1. Enter  sjsugis  into the URL box and click Continue.
2. Click SJSU Okta.
3. Sign in with your SJSU TowerID number and password again.
4. ArcGIS Pro will be activated and ready to use.

1. Go to this link to download .NET Desktop Runtime 6.0.8 (x64). A popup should
immediately appear to download.

2. Once it is downloaded, run the downloaded file and click Install.
3. Once the installation is complete, attempt "Downloading ArcGIS Pro" from step 5 again.

The error should not occur.

Licensing of ArcGIS Pro

Troubleshooting
ArcGIS Pro gives the error “ArcGIS Pro requires microsoft .NET Desktop
Runtime (x64). To download and install Microsoft Windows Desktop
Runtime - 6.0.5 (x64) or greater, visit the Microsoft website or contact
your system administrator.”

https://dotnet.microsoft.com/en-us/download/dotnet/thank-you/runtime-desktop-6.0.6-windows-x64-installer


Information about R, SPSS, etc.

Statistics Software



Statistics Software

Step 1:

Submit an iTicket to request SPSS v.25

Step 2: Install

1. From the files shared with you, download the Installation File that corresponds with your
operating system:

SPSS_Statistics_25_mac_dmg
SPSS_Statistics_25_win64.exe

2. Run the Installer:
MacOS:

Open the Installation Application and Run Installer
Select “Yes” when it asks if you "are you sure you want to open it"
English → Ok

Windows:
Open the Installation Application
Select “Yes” when it asks if you want “to allow this app to make changes to
your device”

3. Select Next
4. Agree to the terms → Next
5. Select “Yes” to install IBM SPSS Statistics - Essentials for Python → Next
6. Accept the terms → Next
7. Accept the terms again → Next
8. Choose a file destination and click Next, or just simply select Next again to use default

folder
9. Select “Install”

10. Select Start SPSS Statistics 25 License Authorization Wizard now → Finish

Step 3: Licensing

Install SPSS v.25 (PASW
Statistics) Windows and Mac
OS

https://helpdesk.mlml.calstate.edu/
https://kb.mlml.sjsu.edu/books/software/page/license-spss-v25-%28pasw-statistics%29-windows-and-mac-os




Statistics Software

Licensing

1. After selecting to start the Licensing Authorization Wizard, a Licensing window should pop
up with two different options of licensing your product.

2. Click Next
3. Select “Authorization Code” (first option) → Next
4. Enter the License Code provided to you from IT → Next
5. Select Finish. You have now successfully installed and licensed your SPSS v.25 software.

If for some reason the licensing window does not begin after installation (or if you need
to do it later), you can also license by accessing IBM SPSS Statistics 25 License
Authorization Wizard from your Windows start menu or from the Applications folder in
Finder on the Mac.

1. Start the IBM SPSS License Authorization Wizard:
Windows:

In the search bar of your Start menu, type in IBM SPSS Statistics.
Right click on the IBM SPSS Statistics 25 License Authorization Wizard
application.
Select Run As Administrator (make sure you are logged into a user account
with full Administrator access rights).
The License Authorization Wizard should then Launch.

macOS:
In your Applications folder, you should see either an IBM folder or an SPSS
folder. Open that folder.
Inside that folder should be a folder called SPSS or Statistics 25 or even SPSS
25 (or less if you have an earlier version). Open that folder.
You may have one or more empty folders after that. Simply open each folder in
succession until you find a non-empty folder.
You should eventually see an application called License Authorization Wizard.
Double-click that program.
The License Authorization Wizard should then launch.

License SPSS v.25 (PASW
Statistics) Windows and Mac
OS



2. Follow licensing the steps above to complete your process.



Statistics Software

Commercial software can be prohibitively expensive. Therefore, we strongly encourage you to try
the open source statistical programming language R which runs on both Windows and Mac. You
can use R like MATLAB, or you can try a myriad of preprogrammed packages for R that perform
many of the same statistical procedures that are found in commercial statistical packages. There is
a learning curve for R, but once you successfully master the R language you will never have to rely
on obtaining an expensive commercial software license. 

There are volumes of helpful R resources but here are several to get you started:

The R website
A Quick and (Very) Dirty Intro to Doing Your Statistics in R
R for MATLAB users

R - The open source
alternative

http://www.r-project.org/
http://www.r-project.org/
http://homes.msi.ucsb.edu/~byrnes/rtutorial.html#1
http://mathesaurus.sourceforge.net/octave-r.html


Statistics Software

NOTE: Submit a Help Desk ticket to get a license key.

1. Run Resampling Stats for Excel from your Start menu or the Desktop icon. This will
open Excel with Resampling Stats enabled.

2. Select the Add-ins tab in the top menu bar.
3. Click the Resampling drop-down menu and select RSXL License. Click Yes when asked

if you want to enter a new license key.
4. Copy and paste the license information you were given in the Help Desk ticket and click 

OK.

Requirements

Microsoft Windows
Microsoft Office 2007 or newer

NOTE: These instructions were written with Office 2010 in mind. There may be minor variations in
older and newer versions.

1. Open Excel.
2. In the File menu (or the Office icon in Office 2007), click Options.
3. Click the Trust Center tab on the left, then the Trust Center Settings... button.
4. Ensure everything in the Add-ins tab is unchecked.

 

Install and License
Resampling Stats 4.0 - Excel
Add-in
Already installed but need a license?

Pre-install Excel Configuration

http://helpdesk.mlml.calstate.edu/


5. In the Macro Settings tab, select the Enable all macros radio button and check the 
Trust access to the VBA project object model checkbox, if available.

 
6. Click OK.
7. In the Add-ins tab, make sure the Manage: list has Excel Add-ins selected, then click 

Go...

8. Check the checkboxes for Analysis ToolPak and Analysis ToolPak - VBA and click OK.

9. Exit Excel.

NOTE: Submit a Help Desk ticket to get a license key.

1. Download and install Resampling Stats from here.
2. Run Resampling Stats for Excel from your Start menu or the Desktop icon. This will

open Excel with Resampling Stats enabled.
3. Copy and paste the license information you were given in the Help Desk ticket and click 

OK.

Check out these links for more information:

http://www.resample.com/support/user-guides/
http://www.resample.com/support/troubleshooting/

Install

Having trouble?

http://helpdesk.mlml.calstate.edu/
http://www.resample.com/wp-content/uploads/2015/01/Resampling-Stats-for-Excel.exe
http://www.resample.com/support/user-guides/
http://www.resample.com/support/troubleshooting/


Statistics Software

JMP Pro
JMP Pro 13 Licenses are no longer available from MLML. If
you'd like to download JMP visit SJSU OnTheHub for discounted

rates or submit an IT Helpdesk Ticket at CSUMB.

https://spartanshops.onthehub.com/WebStore/OfferingsOfMajorVersionList.aspx?pmv=4a88ecf1-e22d-e811-8101-000d3af41938&cmi_mnuMain=df783b53-081b-de11-9c12-0030485a8df0&cmi_mnuMain_child=78d793bc-b838-dd11-abb7-0030485a6b08&cmi_mnuMain_child_child=2ff73789-74c7-e011-ae14-f04da23e67f6&cmi_mnuMain_child_child_child=2a1143f0-74c7-e011-ae14-f04da23e67f6
https://csumb.teamdynamix.com/TDClient/Requests/ServiceDet?ID=23975


Statistics Software

1. Login to the San Jose State University MATLAB Portal.
NOTE: You will need to create a MathWorks account using your SJSU email address.
(Please submit an IT Help Desk Ticket if you do not have an SJSU email address.)

2. Follow the instructions in the SJSU MatLab QuickStart Guide to download and install
MatLab.

How to Install MatLab

http://www.mathworks.com/academia/tah-portal/san-jose-state-university-31511582
https://helpdesk.mlml.calstate.edu/
https://drive.google.com/file/d/1JeIWbccDBTh6bMOiTfUh2BeNZC1A_H5e/view?usp=sharing

